SOLVED CentOS 7.9.2009 & WHM v100.0.4 breaks mySQL?

Operating System & Version
CentOS 7.9.2009
cPanel & WHM Version
v100.0.4

macteacher

Registered
Oct 23, 2007
3
1
53
I updated my CentOS last night and that freed up the update to v100.0.4. Everything completed without issue, but now I am getting Mariadb service errors:

Nov 23 15:53:01 server1.g4vhosting8.com systemd[1]: Starting MariaDB 10.5.13 database server...
Nov 23 15:53:01 server1.g4vhosting8.com mariadbd[23220]: 2021-11-23 15:53:01 0 [Note] /usr/sbin/mariadbd (mysqld 10.5.13-MariaDB) starting as process 23220 ...
Nov 23 15:53:01 server1.g4vhosting8.com systemd[1]: mariadb.service: main process exited, code=exited, status=1/FAILURE
Nov 23 15:53:01 server1.g4vhosting8.com systemd[1]: Failed to start MariaDB 10.5.13 database server.
Nov 23 15:53:01 server1.g4vhosting8.com systemd[1]: Unit mariadb.service entered failed state.
Nov 23 15:53:01 server1.g4vhosting8.com systemd[1]: mariadb.service failed.

What is the best way to fix this?
 

macteacher

Registered
Oct 23, 2007
3
1
53
Anthony,

Thank you for the quick response. I just got your response and went to run the commands requested and my hosting company has fixed the issue. I am just checking to see what they needed to do in order to fix. I would like to know what caused the issue and what was done to remedy it (for future reference).

I will update when I have more details.
 

macteacher

Registered
Oct 23, 2007
3
1
53
Just to follow-up on this - the hosting provider fixed the issue by moving the MySQL PID file from /run to /mysql.

Not sure why an automated update would necessitate this, but it has fixed the issue.
 
  • Like
Reactions: cPanelAnthony