The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

centos 7 slower?

Discussion in 'General Discussion' started by uk01, Jul 29, 2015.

  1. uk01

    uk01 Well-Known Member

    Joined:
    Dec 31, 2009
    Messages:
    50
    Likes Received:
    1
    Trophy Points:
    8
    Hi we have recently set up 2 new vm's.

    Host is esxi e3 v2 with 32GB ram and 4x512 samsung 850 ssd raid 10

    Vm1
    Centos 6.6 2vcpu 4GB ram
    Apache 2.2 php 5.4 Cpanel 11.50 build 29
    Filesystem ext4 LVM (dev/mapper/... / etc)
    0-0.3 load at present

    Vm2
    Centos 7.1 2vcpu 4GB ram
    Apache 2.4 php 5.4 Cpanel 11.50 build 29
    Filesystem XFS default (rootfs / and /dev/sda1 /boot)
    0 load

    Vm1 has been in use for 1 month and runs very fast. We set this up before 11.50 was finalised with Centos 7 support. Logging into WHM, the pages load almost instantly.

    We have just set up Vm2 now Centos 7 is fully supported. All configurations are exactly the same, the only difference is the Centos 7 VM running XFS filesystem and Apache 2.4.
    However, logging into WHM, it's slightly sluggish with a couple of seconds delay and clicking some pages the response seems not as snappy as the Centos 6.6 vm.

    The only other difference is the Centos 7 vm is on a trial cpanel license so that could be "checking cpanels servers" each time the page loads.

    Is there anything else it could be?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Do any of these servers host content (e.g. databases, websites), or are both empty servers? Do you notice any disk I/O differences? This thread is intended for high load averages, but it includes a number of commands that you might find useful for troubleshooting slowness:

    Troubleshooting High Loads On Linux Systems

    Thank you.
     
  3. uk01

    uk01 Well-Known Member

    Joined:
    Dec 31, 2009
    Messages:
    50
    Likes Received:
    1
    Trophy Points:
    8
    Hi Michael,
    The Centos 6.6 vm now hosts several websites, email and databases and that's the faster, snappier one.

    The Centos 7 has absolutely nothing on it and it seems a little slower. It's only slight, but noticable when logging into WHM.

    IO etc are minimal, latency on the Centos 6.6 is max 1 and on the Centos 7 it's 0. (SSD host). There is no obvious reason for the slight sluggishness only it could be something in Apache 2.4 or a module which needs turning off or configuring differently to 2.2.

    Or it's the XFS filesystem set up

    Or it's simply that Centos 6 is more stable and tuned to Cpanel etc.
    I'll take a look at the thread you supplied to see if I spot anything I can check.
    Cheers
     
Loading...

Share This Page