CentOS v5.0 with the CURRENT version 11.2-CURRENT_11480


Nov 29, 2003
I figured I'd post this for anyone else who had my problem and runs into this thread like I did.

I had problems with installing courier on centos 5 as well, but the reason was different:
In the centos release file (/etc/redhat-release) it said release 5 ... and the script tried using /centos/5/ in the urls to get the files... these are 404s (I really recommend that cpanel people add a symlink 5->5.0). I changed it to 5.0 in /etc/redhat-release, and then it worked fine.
Last edited:


Well-Known Member
Apr 9, 2006
Hmmm, that's odd. Technically the various up scripts (e.g. courierup) do this for most of the directories within /usr/local/cpanel/rpm-build It's that they only miss the tmp directory, thus needing the chowning on tmp.

Which version of cPanel did this occur in?
This happened for me in a CentOS 5.0 DomU in Xen with cPanel 11 Edge, FC6 worked the same at the time, but I have since done fresh bare metal installs of FC6/cPanel 11 Current and they have all been flawless.