The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Certificate and https issue.

Discussion in 'General Discussion' started by AlfredW, Nov 30, 2008.

  1. AlfredW

    AlfredW Registered

    Joined:
    Mar 16, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello,
    I am totally new and ignorant to hosting and cpanel issues.
    I have domain www.alfredsmassage.com
    When I go to http://alfredsmassage.com I see my web site.
    When I go to https://alfredsmassage.com first I am warned by my browser that the sites certtificate is no good. Then when I continue on I see some other site/file/directory that I am unfamiliar with.
    when I go to my C-panel I can't find any sign of this other file.

    I also notice that when I sign onto my cpanel I first get a warning that my certificate is not good.


    Obviosly I am in gret need of education. In addition to dealing with the above problems I would like to find out where I can learn more about servers and websites and my cpanel and my whm.
    thanks to all for any help,
    Alfred
     
  2. cpanelinfoseeker

    cpanelinfoseeker Well-Known Member

    Joined:
    Oct 25, 2002
    Messages:
    325
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    NE Illinois
    cPanel Access Level:
    Root Administrator
    The name is wrong on the certificate:
    www.optica4you.com is not the same as https://alfredsmassage.com.

    Second problem is the date:
    4/8/2008 to 7/8/2008 is not current.

    Install a certificate with the correct domain name and date, and it should work better. It may also be the host installed the wrong certificates on several sites as www.optica4you.com has another domain name associated with their certificate also.

    Ron
     
  3. AlfredW

    AlfredW Registered

    Joined:
    Mar 16, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I am confused about how the www.optica4you.com got on to my site/domain.
    and where is it?
    I have searched my entire public-html directory and I don't see it. How do I get it off of my site?

    Thanks, Alfred
     
  4. cpanelinfoseeker

    cpanelinfoseeker Well-Known Member

    Joined:
    Oct 25, 2002
    Messages:
    325
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    NE Illinois
    cPanel Access Level:
    Root Administrator
    That is the certificate that is being presented from your site. I would re-install the correct certificate to correct the problem. I would have no clue how the wrong certificate was installed on your domain, I just read what was there.

    Ron
     
  5. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Sounds like your not on a dedicated IP, if you want SSL without errors you need a dedicated IP and you need to purchase a valid SSL cetrificate then install it. It also sounds like you are a shared or reseller customer so I would also suggest you contact your hosting provider for help.
     
    #5 rhenderson, Nov 30, 2008
    Last edited: Nov 30, 2008
Loading...

Share This Page