The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cgi-bin folder keeps appearing!

Discussion in 'General Discussion' started by DreamPhysix, Apr 6, 2011.

  1. DreamPhysix

    DreamPhysix Well-Known Member

    Joined:
    Sep 30, 2009
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    I want the cgi-bin folder to stop coming back to my public_html folders once I delete them. I disabled CGI for the account. Any advice?
     
  2. DreamPhysix

    DreamPhysix Well-Known Member

    Joined:
    Sep 30, 2009
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    bump * bump * bump
     
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    What command is causing the cgi-bin folder to reappear on the account? Is it the nightly upcp or what precisely? At this point, we would need more information on what is triggering the folder to re-appear to track down how to prevent it.
     
  4. DreamPhysix

    DreamPhysix Well-Known Member

    Joined:
    Sep 30, 2009
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    From what I've gathered, it does it when I FTP in I think.
     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I tested removing the cgi-bin folder on an account on a cPanel machine, switching CGI to off in WHM > Account Modification area, then using FileZilla to FTP into the account. The cgi-bin folder did not reappear at that point.

    Next, I tried running /scripts/upcp --force on the machine, and again the cgi-bin did not reappear on the account.

    We'd need confirmation on what is triggering the folder to re-appear. Since I cannot reproduce the issue, I cannot say how to prevent it.

    Of note, if it does end up being FTP that triggers it in your case, please provide your FTP client details (what client you are using). If this is something like FrontPage, then it is likely re-adding the folder when publishing. For further details, you may also want to provide the full FTP log from login until the folder appears so we can view the command history.
     
  6. DreamPhysix

    DreamPhysix Well-Known Member

    Joined:
    Sep 30, 2009
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    I'm having difficult recreating it as it appears to be almost random to me, but I'll see what I can do. "* Automatically create a cgi-bin script alias. This setting can be individually overridden during account creation." is already set to "No." Note that I am using sFTP through WinSCP.
     
  7. DreamPhysix

    DreamPhysix Well-Known Member

    Joined:
    Sep 30, 2009
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Now I'm starting to think that it has something to do with SSH/sFTP, because when I connect with FTP, it doesn't seem to create the folder.
     
  8. Jamroar

    Jamroar Member

    Joined:
    Aug 23, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    ON, Canada
    Having noticed this lately, and coming across this thread, I did some testing. I can confirm that the cgi-bin folder is being re-created as soon as I connect via SFTP.
     
Loading...

Share This Page