The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cgi-bin not working in a new account

Discussion in 'General Discussion' started by SupermanInNY, Oct 11, 2005.

  1. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    [RESOLVED] cgi-bin not working in a new account

    [RESOLVED] - SEE BELOW

    Hi all,

    I have a user who wants to add CGI option to his account.
    Initially he did not have the cgi option enabled.

    Since this is a new account, I've deleted the account and recreated it with the CGI option enabled.
    I get Server Errors:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@domain.com and inform them of the time the error occurred, and
    anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    ____________________________________________________________________________________________________________


    Apache/1.3.33 Server at domain.com Port 80



    The file that I have there is called perldiver.cgi and it is chowned to the username and group corrrectly and has 755 on it.

    Where do the CGI enabled/disabled is set? Perhaps it is still pointing to the Disabled entry when I first created the account and it didn't update?

    The same script works fine in a different account.
    The httpd.conf file shows as follow:



    <VirtualHost 1.2.3.4>
    ServerAlias domain.com
    ServerAdmin webmaster@domain.com
    DocumentRoot /home/domain/public_html
    BytesLog domlogs/domain.com-bytes_log
    ServerName www.domain.com

    User domain
    Group domain
    CustomLog /usr/local/apache/domlogs/domain.com combined
    ScriptAlias /cgi-bin/ /home/domain/public_html/cgi-bin/
    </VirtualHost>

    Once last thing:

    The domain has not resolved yet, so I'm using lynx via ssh to access the pages.

    any suggestions?

    -Alon.

    [RESOLVED] - SEE BELOW
    I followed the instrutions :)
    I went to the server error log and tailed it.

    /usr/local/apache/logs => tail -f error_log

    I then saw the error it generated and the reason.
    The user has uploaded a .htaccess file to the cgi-bin area:


    [Tue Oct 11 10:36:16 2005] [alert] [client 1.2.3.4] /home/domain/public_html/cgi-bin/.htaccess: Options not allowed here
    [Tue Oct 11 10:36:16 2005] [error] [client 1.2.3.4] File does not exist: /home/domain/public_html/500.shtml

    I renamed the .htaccess to .htaccess-old and Voilla,. the file pulls up fine.

    -Alon.
     
    #1 SupermanInNY, Oct 11, 2005
    Last edited: Oct 11, 2005
Loading...

Share This Page