SOLVED cgi:error when I switch from php56 to php70

AndyX

Well-Known Member
Sep 25, 2015
104
13
68
Los Altos, CA
cPanel Access Level
Root Administrator
Currently I have ea_php56 selected and my XenForo forum runs perfectly. But when I switch to ea_php70 there is a problem, image attachments are broken. The error_log shows cgi:error message:

Code:
[Wed Jan 18 01:47:11.242038 2017] [cgi:error] [pid 6275] [client 50.156.102.222:50093] AH01215:   thrown in Unknown on line 0: /usr/local/cpanel/cgi-sys/ea-php70, referer: http://www.southbayriders.com/forums/threads/154530/
In addition the XenForo server error log shows these type of error messages:

Code:
Error Info
ErrorException: Unknown: Detected an illegal character in input string - Unknown:0
Generated By: hsimpson, Today at 5:55 PM
Stack Trace

#0 [internal function]: XenForo_Application::handlePhpError(8, 'Unknown: Detect...', 'Unknown', 0, NULL)
#1 {main}

Request State

array(3) {
  ["url"] => string(56) "http://www.southbayriders.com/forums/attachments/506441/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
I made sure that all the PHP Extension were the same between php56 and php70.

Checking Google for the error message, it mentions iconv, but iconv is installed on both php56 and php70.
 

AndyX

Well-Known Member
Sep 25, 2015
104
13
68
Los Altos, CA
cPanel Access Level
Root Administrator
Problem solved!

I just updated ea-php71 by making sure all the PHP Extensions were the same as in ea-php56 and now the forum attachments work perfectly using ea-php71. I was also able to enable PHP-FPM.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Problem solved!

I just updated ea-php71 by making sure all the PHP Extensions were the same as in ea-php56 and now the forum attachments work perfectly using ea-php71. I was also able to enable PHP-FPM.
Hello,

I'm happy to see the issue is now solved. Thank you for updating us with the outcome.