Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

CGI , Internal Server Errors server wide

Discussion in 'General Discussion' started by semaj, Mar 25, 2003.

  1. semaj

    semaj Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    156
    Any cgi script that was previously on the servers work but any new script added today gives a Internal Server Error.

    Yes they are uploaded in binary, chmod 755, path to perl /usr/bin/perl .

    Could it be a cpanel upgrade that caused it, this is happening server wide on two servers.

    Upgraded to Cpanel 6.0.0-S109 lastnight.

    Any Ideas??????

    Update:
    Add -W to path to perl & the scripts work, What is the fix & what is causing the problem?

    See here:
    Without the -W http://www.urlf.com/cgi-bin/xxxx.cgi

    With the -W http://www.urlf.com/cgi-bin/yyyy.cgi
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 semaj, Mar 25, 2003
    Last edited: Mar 25, 2003
  2. daveganley

    daveganley Registered

    Joined:
    Jun 27, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    London UK
    I tried adding the -w to my script and it also worked.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice