The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CGI not work

Discussion in 'General Discussion' started by mahdy_sharifi, Jul 12, 2012.

  1. mahdy_sharifi

    mahdy_sharifi Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hello :

    some user cgi folder not work , no file that store in this directory not served from web server , Apache error log :

    Code:
    2012-07-12 15:16:55.794 [INFO] [37.98.24.175:57294-0#APVH_xxxx] File not found [/usr/local/apache/cgi-bin/ubr_upload.pl]
    2012-07-12 15:28:42.407 [INFO] [HTAccess] Updating configuration from [/home2/xxxx/public_html/.htaccess]
    2012-07-12 15:29:24.981 [INFO] [37.98.24.175:58158-0#APVH_xxxx] File not found [/usr/local/apache/cgi-bin/test.php]
    
    
    How Can resolved this issue ?
     
  2. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    386
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Hello,

    Login to WHM >> Account Functions >> Modify an Account >> Select the particular account >> Click modify >> Under "Privileges" block make sure that " CGI Privilege" is enabled >> Save.

    That should fix it!

    Thank you.
     
  3. mahdy_sharifi

    mahdy_sharifi Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    already enabled , Problem exists.

    - - - Updated - - -

    already enabled , Problem exists.
     
  4. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    386
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Login to SSH as root >> Edit /usr/local/apache/conf/httpd.conf >> navigate to the virtual host section of the particualr domain >> in the virtualhost block of the particualr domain check the existence of a line like follows , where "user" is the cpanel username of that domain

    ScriptAlias /cgi-bin/ /home/user/public_html/cgi-bin/

    If exists, try to do a graceful apache restart and try again. if don't exist, try to disbale - enable the CGI privilege and and check the virtualhost again, it should appears there ( normlly ).

    Still you cannot isolate the issue, you may contact your host support or cpanel support, because it is how it should work :)
     
Loading...

Share This Page