Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

CGI path problem - host no help

Discussion in 'General Discussion' started by Canned_Heat, Aug 30, 2004.

  1. Canned_Heat

    Canned_Heat Member

    Joined:
    Oct 8, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    151
    Cannot execute scripts. Get 500 error.
    I'm setting path exactly as indicated on cpanel page and chmod 755.

    Crediblehost support no help.

    Is there a simple utility that can be uploaded to the root directory that allows me to set a path in the script so as to test the path and/or to test if perl has been configured correctly for my hosted account?

    Thx.
     
  2. OCX

    OCX Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    166
    in the cgi file..make sure your path to perl is set

    its either in these 2 places normally

    /usr/bin/perl

    or
    /usr/local/bin/perl

    put cgi scripts in your cgi-bin folder
     
  3. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    4
    Trophy Points:
    343
    Location:
    ON, Canada
    Add this:

    use CGI::Carp qw(fatalsToBrowser);

    near the beginning of the script. It will print out the problems to the browser, usually.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice