Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

cgi/perl scripts NOT excecuting

Discussion in 'General Discussion' started by mpi, Apr 6, 2006.

  1. mpi

    mpi Well-Known Member

    Joined:
    Mar 29, 2006
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    156
    i cannot run cgi scripts in ANY of the created accounts.

    in other words, cgi/perl scripts run fine here:

    /usr/local/apache/cgi-bin

    but they do NOT even excecute in i.e:

    /home/username/cgi-bin

    and yes, i have set the correct permissions.

    what can be causing this?
     
  2. xidica

    xidica Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Texas
    Make sure you have the correct ScriptAlias directives inside each VirtualHost directive in Apache :

    Here's an example :

    Code:
    <VirtualHost xxx.xx.xxx.xx>
    ServerAlias www.xxxx.xxx.xx xxxx.xxx.xx
    ServerAdmin webmaster@xxxx.xxx.xx
    DocumentRoot /home/xxxx/public_html
    BytesLog domlogs/xxxx.xx.xx-bytes_log
    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled xxxx
    </IfModule>
    ServerName www.xxxx.xxx.xx
    ScriptAlias /cgi-bin/ /home/xxxx/public_html/cgi-bin/
    User xxxx
    Group xxxx
    CustomLog domlogs/xxxx.xxx.xx combined
    </VirtualHost>
    
     
  3. mpi

    mpi Well-Known Member

    Joined:
    Mar 29, 2006
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    156
    paths


    if you're referring to the correct paths, i checked. they are ALL correct.
     
  4. mpi

    mpi Well-Known Member

    Joined:
    Mar 29, 2006
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    156
    code

    edited.

    Note: already figured it out.
     
    #4 mpi, Apr 6, 2006
    Last edited: Apr 6, 2006
  5. mpi

    mpi Well-Known Member

    Joined:
    Mar 29, 2006
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    156
    Wow!

    holy mother of god....it was missing a set of quotes...took me over 4 hours to figure out...
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice