Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

CGI/Requies.pm not Found

Discussion in 'General Discussion' started by kalelme, Nov 6, 2002.

  1. kalelme

    kalelme Member

    Joined:
    Nov 1, 2002
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Barcelona, Edo. Anzoategui, Venezuela
    Can't locate CGI/Request.pm in @INC (@INC contains: /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl .) at /home/lucier/public_html/cgi-bin/f_to_f_ex.cgi line 6.

    I try install in the WHM panel Intall Module Perl the CGI::Request

    but

    spawn /usr/local/cpanel/whostmgr/bin/perlmod -i
    CGI::Request

    CPAN: Storable loaded ok
    Going to read /root/.cpan/Metadata
    Database was generated on Tue, 05 Nov 2002 14:53:57 GMT
    File::Spec is up to date.
    Digest::MD5 is up to date.
    Compress::Zlib is up to date.
    Archive::Tar is up to date.
    Data::Dumper is up to date.
    Net::Telnet is up to date.
    Net::Cmd is up to date.
    Term::ReadKey is up to date.
    Term::ReadLine::Perl is up to date.
    CPAN::WAIT is up to date.
    CPAN is up to date.
    Strange distribution name [UserID CGIP]Running install for module CGI::Request
    Running make for UserID CGIP
    CPAN: LWP::UserAgent loaded ok
    Fetching with LWP:
    http://ftp.cpanel.net/pub/CPAN/authors/id/UserID CGIP
    Fetching with LWP:
    http://ftp.cpanel.net/pub/CPAN/authors/id/UserID CGIP.gz

    Trying with &/usr/bin/lynx -source& to get
    http://ftp.cpanel.net/pub/CPAN/authors/id/UserID CGIP

    Can't Access `file://localhost/usr/local/cpanel/whostmgr/docroot/CGIP'
    Alert!: Unable to access document.

    lynx: Can't access startfile

    Trying with &/usr/bin/lynx -source& to get
    http://ftp.cpanel.net/pub/CPAN/authors/id/UserID CGIP.gz

    Can't Access `file://localhost/usr/local/cpanel/whostmgr/docroot/CGIP.gz'
    Alert!: Unable to access document.

    lynx: Can't access startfile

    Trying with &/usr/bin/ncftpget& to get
    http://ftp.cpanel.net/pub/CPAN/authors/id/UserID CGIP
    NcFTPGet 3.1.3

    Usages:
    ncftpget [flags] remote-host local-dir remote-path-names... (mode 1)
    ncftpget -f login.cfg [flags] local-dir remote-path-names... (mode 2)
    ncftpget [flags] ftp://url.style.host/path/name (mode 3)
    ncftpget -c [flags] remote-host remote-path-name & stdout (mode 4)
    ncftpget -c [flags] ftp://url.style.host/path/name & stdout (mode 5)

    Flags:
    -u XX Use username XX instead of anonymous.
    -p XX Use password XX with the username.
    -P XX Use port number XX instead of the default FTP service port (21).
    -d XX Use the file XX for debug logging.
    -a Use ASCII transfer type instead of binary.
    -t XX Timeout after XX seconds.
    -v/-V Do (do not) use progress meters.
    -f XX Read the file XX for host, user, and password information.
    -A Append to local files, instead of overwriting them.
    -z/-Z Do (do not) not try to resume downloads (default: -z).
    -E Use regular (PORT) data connections.
    -F Use passive (PASV) data connections (default).
    
    -DD Delete remote file after successfully downloading it.


    And in my httpd.conf i no have active the line

    &Directory /home/*/public_html&
    Options -Indexes
    &/Directory&

    that function has these lines

    I have the configure my perl but how.

    Please Help mi
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice