WayneC

Registered
Jul 18, 2019
1
0
1
Salt Lake City, Utah
cPanel Access Level
Website Owner
I am a website owner. For the past 3 days ALL of my CGI scripts are not being found. No changes have been made in the site. They just stopped.

The error message is:
lscgid: execve():/home/califonr/public_html/thedirectory.org/cgi-bin/lookup1.cgi: No such file or directory

My hosting provider: - Removed - has been contacted numerous times during the past 2 days but the problem persists. They say they are "escalating" it but nothing is done.

Maybe you can tell me what they need to do to get the scripts working again. They don't seem to know or care.

To duplicate the problem, go to:

- Removed - enter any telephone prefix and submit.

Thank you.
 
Last edited by a moderator:

keat63

Well-Known Member
Nov 20, 2014
1,904
254
113
cPanel Access Level
Root Administrator
I'm not sure that you'll find a resolution on here, other than your hosting provider will need to investigate.

What I could add is to check if the files or folders you mention actually exist.
Using file manager on your cpanel account, or via FTP.

lscgid.exe appears to be asccociated with LiteSpeed, which I beleive is an alterntive web server software to Apache.
More than likely setup by your web hosts.

I'm not familiar with LiteSpeed, is there an option in your Cpanel to disable it and switch to Apache ??
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,216
463
lscgid: execve():/home/califonr/public_html/thedirectory.tld/cgi-bin/lookup1.cgi: No such file or directory
Hello @WayneC,

The following document is a good place to start when troubleshooting Perl/CGI script errors:

Troubleshooting Guide for Perl and CGI Scripts - cPanel Knowledge Base - cPanel Documentation

If that doesn't help, browse to cPanel >> Home >> Metrics >> Errors and see if you notice any additional error log output here when reproducing the issue. Feel free to post the relevant line here (ensuring to replace real domains and IPs with examples in the pasted output).

Thank you.