The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cgi script not working for all the users

Discussion in 'General Discussion' started by activa, Jan 6, 2011.

  1. activa

    activa Well-Known Member

    Joined:
    May 23, 2006
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Morocco
    cPanel Access Level:
    Root Administrator
    Hello

    i have find that all the custom cgi script not working in the users website . (not cpanel cgi script) , in the error log i found

    Code:
    script not found or unable to stat: /usr/local/apache/cgi-bin/test.cgi
    the script is placed in the user directory /home/xxxxx/public_html/cgi-bin/test.cgi

    in my httpd config i found

    Code:
    <IfModule alias_module>
        ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"
    </IfModule>
    i have already cgi previlige added for the account .

    from where the probleme ?
     
  2. activa

    activa Well-Known Member

    Joined:
    May 23, 2006
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Morocco
    cPanel Access Level:
    Root Administrator
    i have added this line in the http config for the directive of the user and it work now


    Code:
    ScriptAlias /cgi-bin/ /home/xxxxxx/public_html/cgi-bin/
    i should add this line for every account manually ?
     
  3. Aldweb

    Aldweb Well-Known Member

    Joined:
    Feb 18, 2004
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    I'm having the same problem. I added in httpd.conf, the following domain settings:

    <IfModule alias_module>
    ScriptAlias /cgi-bin/ /home/amazonli/www/cgi-bin/

    </IfModule>

    It works, but when I upgrade the apache's httpd.conf configuration disappears. Would any way to fix this problem, because several times a week, I have to return the alias.

    Thanks
     
  4. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    386
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you have CGI enabled for the particular user? Naviagte to modify account >> select the particular user and you can see a "CGI check box", which will disbale / enable CGI for that user.

    Thank you.
     
Loading...

Share This Page