The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cgi-sys problem

Discussion in 'General Discussion' started by Darkedge, Jan 15, 2003.

  1. Darkedge

    Darkedge Active Member

    Joined:
    Aug 16, 2001
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    I am hoping someone can help me wth this.

    I am running cpanel on freebsd.

    THe only problem I am running into is the script alias for the cgi-sys is not working properly. when one of the customer run the cgi from there they get an internal error. The error log shows an premature end of script headers and the su_exec log shows
    [2003-01-16 00:15:35]: info: (target/actual) uid: (xclusiv/xclusiv) gid: (xclusiv/xclusiv) cmd: cgiemail
    [2003-01-16 00:15:35]: error: file is either setuid or setgid: (/usr/local/cpanel/cgi-sys/cgiemail) this then I tried making sure that the files were chmod 755 and now I get this.
    \
    [2003-01-16 00:19:35]: info: (target/actual) uid: (xclusiv/xclusiv) gid: (xclusiv/xclusiv) cmd: cgiemail
    [2003-01-16 00:19:35]: error: target uid/gid (1022/1023) mismatch with directory (0/0) or program (0/0) or trusted user (0/10)
    I am hoping that someone has some ideas and or is running freebsd with this opiton succesffuly and can tell me what their permissions are set to. I have checked the normal stuff and can't find anything wrong.
    ALso the direcotry and files are owned by root and wheel which is what it is on redhat should it be different for freebsd.
     
Loading...

Share This Page