Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Cgi-Wrapper /scgi-bin

Discussion in 'General Discussion' started by mickalo, Aug 12, 2002.

  1. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    776
    Likes Received:
    4
    Trophy Points:
    318
    Location:
    N.W. Iowa
    Cancel this post, I found the problem. The scgiwrap binary executable was chmoded improperly. It's working fine now.

    =========================================

    Hello,

    Hoping someone can help me out on this one.

    All of a sudden all our accounts that have enabled the cgi-wrapper to use the &/scgi-bin& on our server stopped running under their own &owner/group&, but instead now run under &nobody&... we had a problem with some folder/files premission settings getting messed up and I think this may also be the case. We do not have suexec enable, this is disabled, but I 'm not sure on the chmod folder setting for the /usr/local/cpanel.

    What would cause the cgi-wrapper to all of sudden run under &nobody& instead of the account's own &owner/group& id's

    Any help would be much appreciated!!

    TIA,
    Mickal;o
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. parag

    parag Well-Known Member

    Joined:
    Aug 16, 2001
    Messages:
    115
    Likes Received:
    0
    Trophy Points:
    316
    [quote:7e708235c5][i:7e708235c5]Originally posted by mickalo[/i:7e708235c5]

    Hello,

    Hoping someone can help me out on this one.

    All of a sudden all our accounts that have enabled the cgi-wrapper to use the &/scgi-bin& on our server stopped running under their own &owner/group&, but instead now run under &nobody&... we had a problem with some folder/files premission settings getting messed up and I think this may also be the case. We do not have suexec enable, this is disabled, but I 'm not sure on the chmod folder setting for the /usr/local/cpanel.

    What would cause the cgi-wrapper to all of sudden run under &nobody& instead of the account's own &owner/group& id's

    Any help would be much appreciated!!

    TIA,
    Mickal;o[/quote:7e708235c5]

    Hi

    I think you must have disabled SuExec.

    Go to your WHM scroll down the server setup menu and then click on Enable/Disable SuExec

    Check whether its enabled or not., If its not enabled then enable it and everything will be ok

    regards,
    Parag
     
  3. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    316
    The wrapper should work without suExec being enabled. Mickalo, what do the permissions look like now that you've reset them?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    776
    Likes Received:
    4
    Trophy Points:
    318
    Location:
    N.W. Iowa
    Problem solved :)

    [quote:2663dc0547][i:2663dc0547]Originally posted by Annette[/i:2663dc0547]

    The wrapper should work without suExec being enabled. Mickalo, what do the permissions look like now that you've reset them?
    [/quote:2663dc0547]

    that's exactly what the problem was, after I did a little more digging.
    once I re-set the file premission setting on the binary, scgiwrap, then
    everything worked fine.

    thanks,
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    316
    I know - that first part was not directed to you. However, my other question is: what are the permissions you set on the scgiwrap? We have the same problem on a couple of boxes, but the permissions look correct when compared to other boxes, and I want to rule out the possibility that the permissions are just wrong everywhere (since we only have complaints on two out of many servers). Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    776
    Likes Received:
    4
    Trophy Points:
    318
    Location:
    N.W. Iowa
    [quote:94489d3f7a][i:94489d3f7a]Originally posted by Annette[/i:94489d3f7a]

    I know - that first part was not directed to you.
    However, my other question is: what are the permissions you set on
    the scgiwrap? We have the same problem on a couple of boxes,
    but the permissions look correct when compared to other boxes, and
    I want to rule out the possibility that the permissions are
    just wrong everywhere (since we only have complaints on two out
    of many servers). Thanks.[/quote:94489d3f7a]

    The scgiwrap should be owned by root, chmod setting should be: 4755
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    316
    Well, that rules that out. Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Daniel

    Daniel Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    316
    I had that problem on a server and found that

    ScriptAlias /scgi-bin /usr/local/cpanel/cgi-sys/scgiwrap

    was not in httpd.conf.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice