The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cgiemail not available?

Discussion in 'E-mail Discussions' started by nyjimbo, Jun 15, 2004.

  1. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    Many of my customers were using cgiemail for a long time as part of their websites. Suddenly in the past couple weeks it appears that the program is not found and when you go to the cgi center in cpanel and click on cgiemail it comes up with a HTTP 404 - File not found.

    Was cgiemail removed from the server?. Is there a way to check if its something to do with the apache config or something else ?.

    Thanks.
     
  2. uneedawebsite

    uneedawebsite Active Member

    Joined:
    Apr 14, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I am having the same problem here. Using the script gives a 404 error.

    Mark
     
  3. paralard

    paralard Well-Known Member

    Joined:
    Mar 2, 2003
    Messages:
    114
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Austin Texas
    Same issue here..... any help?
     
  4. outie

    outie Member

    Joined:
    Mar 22, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    The URL is changed from cgi-bin/cgiemail TO cgi-sys/cgiemail

    This was not changed in the cpanel template for some reason.
     
  5. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    A locate command will do the job for you.

    /usr/local/cpanel/cgi-sys/cgiemail
     
  6. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    can you make a directory cgi-sys on your public_html directory and copy this cgiemail to that dirctory and add the server alias correspondingly, you might be able get a work around. Please have a try and let me know
     
  7. outie

    outie Member

    Joined:
    Mar 22, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Just have your clients use cgi-sys/cgiemail instead of cgi-bin/cgiemail.
     
  8. uneedawebsite

    uneedawebsite Active Member

    Joined:
    Apr 14, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    We tried using cgi-sys but get a 400 error when using that.

    CGIEMAIL is located in cgi-bin and has the correct permissions.
     
  9. skanwhost

    skanwhost Member

    Joined:
    Dec 24, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    cgi-sys/cgiemail missing?

    I'm receiving the same error...

    The apache error log reads:

    'Premature end of script headers: /usr/local/cpanel/cgi-sys/cgiemail'

    This error started happening sometime between Saturday afternoon and this morning? Any help would be greatly appreciated.

    Thanks,

    Sydney
     
  10. Paul Kurucz

    Paul Kurucz Member

    Joined:
    Aug 24, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Same Problem

    cgiemail was working before ... now 500 Internal Errors checked permissions on cgi-sys .... root wheel 755 no problem. Looked through all the threads but haven't found anyone with a definitive solution.
     
Loading...

Share This Page