The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cgiwrap problems

Discussion in 'General Discussion' started by techid, Jan 1, 2003.

  1. techid

    techid Member

    Joined:
    Aug 5, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    When someone tries to access the /scgi-bin directory on one of my servers they get the Server 500 error, in the apache error log it says

    Premature end of script headers: /usr/local/cpanel/cgi-sys/scgiwrap

    Does anybody have any ideas? I have double checked the file permissions and have run /scripts/fixcgiwrap
     
  2. Danks

    Danks Active Member

    Joined:
    Oct 10, 2001
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    do you have suexec turned on? If so scgi-wrap won't work. There wouldn't be a reason to use it anyway with suexec turned on.
     
  3. techid

    techid Member

    Joined:
    Aug 5, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    With SuExec on or off on this server it does the same thing.
     
  4. canaca

    canaca Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    chown the script to :

    chown -Rf root.wheel scgiwrap
    chmod 4755 scgiwrap

    that should do it

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page