The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Change Default File permissions

Discussion in 'General Discussion' started by clicktrack, Mar 29, 2010.

  1. clicktrack

    clicktrack Registered

    Joined:
    Mar 13, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I was on shared hosting plan with Hostgator. Now I have dedicated server. I have installed fantastico and now when I add a wordpress site I can not edit any files from the wordpress admin area. So if I change my permalinks I have to manually edit the .htaccess file. If I go to editor I can't save any changes to theme files, etc.

    I could do this with hostgator in my shared account and I would like to set it up so it works that way with my users for my dedicated server.

    Can anyone lead me in the correct direction to fix this.

    Thanks
     
  2. DirectHorizon

    DirectHorizon Member

    Joined:
    Nov 24, 2009
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    If I am correct I believe you need to change the permissions on the file that you are working on to writeable.


    But make sure you change it back when you are done working on the file.
     
  3. clicktrack

    clicktrack Registered

    Joined:
    Mar 13, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I know how to manually change the file permissions to allow me to edit the file. What I want is when I install wordpress through fantastico that the settings are set so wordpress can update files. It is setup this way on my shared plan with Hostgator.

    With my dedicated server anytime I install a wordpress it is not able to change any files and I have to go manually update each file permission that I want to allow wordpress to change.

    Since this is possible with Hostgator I am sure there is some setting either in cpanel or whm admin interface to make it the way I want it.
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I recommend contacting the makers of Fantastico about this issue with Fantastico: netenberg.com || creating possibilities

    Alternatively, you can go to WHM -> cPanel -> Install cPAddons, select WordPress, click Save and then go to cPanel -> Site Software -> WordPress and install WordPress that way.
     
  5. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    I will take a wild guess that you setup your dedicated server with "DSO" based PHP just reading over your description of your problem here.

    I would go with either SuPHP or FCGI for your PHP and make sure all the files on your web site are owned by your account owner instead of the generic user "nobody".

    Additionally for the settings in WHM for Fantastico, you will find an option to tell Fantastico that you have "phpSuExec" and that option should be enabled whenever you use phpSuExec, SuPHP, or FCGI on your server.
     
Loading...

Share This Page