The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Change DKIM selector from 'default'

Discussion in 'E-mail Discussions' started by kpmedia, Oct 31, 2013.

  1. kpmedia

    kpmedia Well-Known Member

    Joined:
    Feb 13, 2011
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA, Europe
    cPanel Access Level:
    Root Administrator
    cPanel sets all servers up to use "default". That's a problem if you use several severs to send mail, and they all insist on being "default".

    Where's the setting to change the default selector used by the server? If not in WHM, what needs to be edited (and likely restarted) via SSH?

    Using EXIM and Dovecot -- the cPanel default mail servers.
     
    #1 kpmedia, Oct 31, 2013
    Last edited: Oct 31, 2013
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    There is no native functionality available to customize the default DKIM records. However, you should be able to implement a manual workaround. Could you provide more details about the specific records you need to configure and your specific server setup?

    Also, feel free to open a feature request for the ability to customize DKIM records at:

    Submit A Feature Request

    Thank you.
     
  3. kpmedia

    kpmedia Well-Known Member

    Joined:
    Feb 13, 2011
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA, Europe
    cPanel Access Level:
    Root Administrator
    - Right now the DKIM selector = "default" ... ie, "default._domainkey.mydomain.com" and signed by the server as "default"
    - I want it set to "anything" (else)

    I'm not sure what else you're after.

    cPanel has to specify the key somewhere -- I just don't know where. I didn't write the software. It's likely an easy edit somewhere in the config files.

    Forcing us to use "default" is not at all compliant with DKIM specs. It has selectors on purpose. If it's can't be changed, that's serious design flaw.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I was unable to find any internal documentation supporting the ability to modify the default entry used for DKIM. You are welcome to open a support ticket so we can take a closer look:

    Submit A Ticket

    You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. artfei

    artfei Registered

    Joined:
    Feb 20, 2014
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi all.

    If anyone is still interested in this there are lines in /etc/exim.conf file

    dkim_remote_smtp:
    driver = smtp
    interface = ${if exists {/etc/mailips}{${lookup{$original_domain}lsearch{/etc/mailips}{$value}{${lookup{$sender_address_domain}lsearch{/etc/mailips}{$value}{${lookup{${perl{get_sender_from_uid}}}lsearch*{/etc/mailips}{$value}{}}}}}}}}
    helo_data = ${if exists {/etc/mailhelo}{${lookup{$original_domain}lsearch{/etc/mailhelo}{$value}{${lookup{$sender_address_domain}lsearch{/etc/mailhelo}{$value}{${lookup{${perl{get_sender_from_uid}}}lsearch*{/etc/mailhelo}{$value}{$primary_hostname}}}}}}}{$primary_hostname}}
    dkim_domain = $sender_address_domain
    dkim_selector = default
    dkim_private_key = "/var/cpanel/domain_keys/private/${dkim_domain}"
    dkim_canon = relaxed

    To have different selectors for different domains you may simply change it from default to ${dkim_domain} or try to configure your own variables.

    With the above I now have:

    DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=nagios.domain.com; s=mydomain.com;
    h=Date:From:Message-Id; bh=g3zLYH4xKxcPrHOD18z9YfpQcnk/GaJedfustWU5uGs=

    Sure with this you should have domainkey TXT record like

    mydomain.com._domainkey.mydomain.com
     
    Ana Blake likes this.
  6. kpmedia

    kpmedia Well-Known Member

    Joined:
    Feb 13, 2011
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA, Europe
    cPanel Access Level:
    Root Administrator
    I already tried changing the exim setting from "default" to something else.

    Code:
    dkim_selector = default
    Code:
    dkim_selector = anything
    That didn't have any effect.
     
Loading...

Share This Page