SOLVED Change Document Root addon domains stuck

Samet Chan

Well-Known Member
Jun 24, 2016
359
32
103
cPanel Access Level
Root Administrator
Twitter
Dear,

I tried to change Document Root in addon domains public_html/example.com to anime.com doesn't work.

It's java console alert up: Document Root Updated: public_html/example.com

Still stuck public_html/example.com, I'm confused.

Screenshot_3.png
Screenshot_1.png
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

I'm unable to reproduce any errors when changing the document root of an addon domain name in the cPanel UI. Could you let us know which version of cPanel is installed on the system, and let us know if you notice any output to /usr/local/cpanel/logs/error_log when this happens? Also, have you tried with a different web browser and verified this isn't related to a specific web browser plugin or setting?

Thank you.
 

Samet Chan

Well-Known Member
Jun 24, 2016
359
32
103
cPanel Access Level
Root Administrator
Twitter
There,
Code:
[2017-04-24 11:44:38 +0200] info [apache_conf_distiller] Creating missing document root /usr/local/apache/htdocs for nobody
[2017-04-24 11:44:38 +0200] info [apache_conf_distiller] Creating missing document root /usr/local/apache/htdocs for nobody
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

Samet Chan

Well-Known Member
Jun 24, 2016
359
32
103
cPanel Access Level
Root Administrator
Twitter
Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thank you.
The problem is solved now.

David Levey said:
I've gone ahead and updated this for you:
====
Updating your system to reflect any changes...

Updating “Restrict document roots to public_html” from “On” to “Off”.
“Restrict document roots to public_html” was updated.

Done.
====

For your reference, in WHM, navigate to the 'Tweak Settings' feature page. On that page, click the 'Domains' tab and the “Restrict document roots to public_html” option should be there.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.

Thank you.