The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Change outgoing IP of exim not working?

Discussion in 'General Discussion' started by noimad1, Jul 29, 2008.

  1. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    Did something change in cpanel 11 recently as far as changing the exim IP address?

    I put this in both my exim.conf and exim_outgoing.conf file:

    remote_smtp:
    driver = smtp
    #interface = ${if exists {/etc/mailips}{${lookup{$sender_address_domain}lsearch{/etc/mailips}{$value}{}}}{}}
    interface = 0.0.0.0
    helo_data = ${if exists {/etc/mailhelo}{${lookup{$sender_address_domain}lsearch{/etc/mailhelo}{$value}{$primary_hostname}}}{$primary_hostname}}

    so as you can see I commented out the old one and put a new interface in (of course i put my IP address in and not 0.0.0.0.0).

    I restarted exim, but mail still comes from the original shared IP address?

    Did I do something wrong?
     
  2. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    Does anyone have any ideas on this? I could really use some help....
     
  3. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    16
    I'd like a fix for this also....
     
  4. jdsilva

    jdsilva Member

    Joined:
    Dec 27, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Disable the option
    "** Send outgoing mail from accounts ip address instead of the main ip address. [Warning: If you turn this setting on you should make sure your reverse dns entries match the ones in /etc/mail_reverse_dns] [?]" in WHM >> Service Configuration >> Exim Configuration

    Now edit exim.conf

    Comment the line "interface = ${if exists {/etc/mailips..." under "remote_smtp:"
    and add

    interface = <IP>

    Do the same in "dk_remote_smtp" too

    This fixed the issue for me.. (Thanks to my admin Hamish):)
     
Loading...

Share This Page