Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Change server response to non existent email

Discussion in 'E-mail Discussion' started by Shood, Jan 29, 2019.

  1. Shood

    Shood Well-Known Member

    Joined:
    Aug 12, 2015
    Messages:
    74
    Likes Received:
    14
    Trophy Points:
    83
    Location:
    Middle East
    cPanel Access Level:
    Root Administrator
    Hello
    If someone send a message to non-exist email for a domain on my server, it reply with a message contains user_account_name@myserver, instead of the original email the sender sent to, so the sender will receive a reply like this:
    Code:
    could not deliver mail to account_name@server1.myserver.ltd.  The account or domain may not exist... etc
    It'ss strange that this issue started from a couple of days although I didn't make any change in Tweak or Exim settings

    (Tweak Settings: Initial default/catch-all) is configured to Fail, and I don't want to use Blackhole because I'm under mail attacks all the time.

    My question: where to control the server reply when receiving a message to non exist email address, I prefer the server to don't send any reply at all, but at least to send a reply that the "fakeemail" instead of "user_account_name" not exist

    Regards
     
  2. velnix

    velnix Member

    Joined:
    Aug 9, 2013
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Value in the Tweak setting can be override from Cpanel settings of the domain/account. Are you sure that it is set to the default ID ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Shood

    Shood Well-Known Member

    Joined:
    Aug 12, 2015
    Messages:
    74
    Likes Received:
    14
    Trophy Points:
    83
    Location:
    Middle East
    cPanel Access Level:
    Root Administrator
    Thank you @velnix
    This issue occurring with all accounts, not for a specific one
     
  4. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,248
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    HI @Shood

    The issue sounds like it's with where the bounce is being sent not that there's an issue with fact that mail to users who don't exist is bouncing.


    Can you tell me what you have set for
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Shood

    Shood Well-Known Member

    Joined:
    Aug 12, 2015
    Messages:
    74
    Likes Received:
    14
    Trophy Points:
    83
    Location:
    Middle East
    cPanel Access Level:
    Root Administrator
    Thank you @cPanelLauren
    I see as detailed in this option that it's for the actual message sender
    anyway EXPERIMENTAL was disabled, I tried both: All and Remote and nothing changed,
    The sender (let's say: anymail@yahoo.com) still receiving cPanel_account_name@myserver.com not exist when he sending to non-existent email (let's say: nomail@mydomain.com) which [mydomain.com] is hosted on [myserver.com] in this example.

    Another setting please?
    Regards
     
  6. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,248
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Shood

    Do you have any exim customizations in place or is there anything present in /etc/exim.conf.local?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice