change /webmail not show hostname server

Jul 18, 2018
8
0
1
Florianopolis, SC, Brazil
cPanel Access Level
Root Administrator
Hello,

I'm trying to access webmail:

http://www.domain.tld/webmail

In the browser bar the address changes to https://hostname.tld:2096/

I want you to continue domain.tld/ and not hostname.tld

I tried to do what is in the attached image but the option is disabled.

I would have to mark "Origin Domain Name" but it is not enabled, how to enable?

Thanks!
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello @marcelo falcao,

This relates to the following option under the Redirection tab in WHM >> Tweak Settings:

Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs. Formerly known as “Always redirect to SSL/TLS”

Here's the description of this option so you are aware of the change that will occur by turning it off:

When a user visits /cpanel, /webmail, /whm, or visits other URLs that redirect to a cPanel service, the system will redirect to an SSL URL for the closest matched domain that the system has a valid certificate. If you disable this option, the system will redirect to the equivalent URL that they visited based on the original request made via HTTPS or HTTP. This option also controls how the system will redirect unencrypted cPanel, Webmail, WHM, and DAV requests to the best matched certificate for the domain when “Require SSL” is enabled. When enabled, it will redirect closest matched domain that the system has a valid certificate for. When it is disabled, it will simply redirect equivalent HTTPS URL.
Thus, the best approach to solve this issue is to ensure a signed SSL certificate is installed for the individual domain name. You can ensure a free signed SSL certificate is installed on the domain name via the AutoSSL feature:

Manage AutoSSL - Version 72 Documentation - cPanel Documentation

Otherwise, you'd need to disable the option noted at the top of this post and then set "SSL redirect destination" to "Original Domain Name".

Thank you.