The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Change webmail so no SSL warning

Discussion in 'E-mail Discussions' started by Bestrafung, May 29, 2012.

  1. Bestrafung

    Bestrafung Active Member

    Joined:
    Apr 2, 2012
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I'm not sure if this is the appropriate place for this or not. Please move it if not. I am setting up a cPanel server and so far everything is working except that when you visit http://clientdomain.com/webmail you are redirected to https://clientdomain.com:2096 and receive an error message about the site being untrusted. From what I understand the only workaround to this is to redirect the client to the server's address so there is no SSL warning. I want the clients to remain on their domain. If you visit the proxy subdomain webmail.clientdomain.com there is no port redirect nor an SSL warning. Is it possible to redirect the /webmail to the webmail subdomain? Or am I overlooking a simple fix to the SSL warning?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    WHM > Server Configuration > Tweak Settings, Redirection tab has some settings you might like to know about.

    The easy fix is to instruct your users on how to accept the cert into their browser which gets rid of the warning and keeps the connection secured.

    Many, many threads on this topic on these forums.
     
  3. Bestrafung

    Bestrafung Active Member

    Joined:
    Apr 2, 2012
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Thanks for the reply. I know there are a lot of threads on this topic but none have worked for me. I've tried setting it to allow non SSL and don't require SSL but it still redirects all non SSL connections to SSL except when using the proxy subdomain. Does anyone have an idea on how to change this? I am currently have another cpanel account with another host that this works on so I know it is possible. You still get the SSL warning if you connect via SSL but they don't require SSL so it's not an issue.
     
  4. Bestrafung

    Bestrafung Active Member

    Joined:
    Apr 2, 2012
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I didn't realize redirects could be cached by the browser. I had to clear cache for another problem and noticed this was fixed as well. I feel stupid about it now but hopefully this helps someone else. Thanks for the help.
     
Loading...

Share This Page