The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Changed FTP port Now Getting ftpd fail emaisl

Discussion in 'Security' started by mimran, Nov 19, 2010.

  1. mimran

    mimran Member

    Joined:
    Dec 16, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I changed default ftp port to a new number, now I'm getting email messages that ftp is failed though FTP is running fine on new port.

    Code:
    ftpd failed @ Fri Nov 19 10:53:54 2010. A restart was attempted automagically.
    Service Check Method:  [tcp connect]
    
    Failure Reason: Unable to connect to port 21
    Is there way to disable these notification or make it listen to new port so that it wont send these notifications again.
     
  2. mimran

    mimran Member

    Joined:
    Dec 16, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Anybody? anyone?
    Please help me stop these e-mails...

    Cpanel being such a big product, why the support forums are so slow to get replies, unlike in any other big company the support should be good.
    Thanks.
     
  3. JeffP.

    JeffP. Well-Known Member

    Joined:
    Sep 28, 2010
    Messages:
    164
    Likes Received:
    9
    Trophy Points:
    18
    Hi mimran,

    The emails you are receiving come from "chksrvd", which is the service checking utility that is part of cPanel. There are 2 options possible since the port has changed:

    1. Log into WHM as root
    2. Click "Service Manager"
    3. On the line that says "ftpd", uncheck the box under the column labeled "Monitor".
    4. Scroll down to the bottom and click "Save"

    That will prevent chksrvd from attempting to see if ftpd is running.

    However, if you'd like still like chksrvd to check to see if ftpd is up and running, then the likely solution would be as follows:

    1. Log into the server via ssh
    2. Become root
    3. cd /etc/chkserv.d/
    4. cp -p ftpd ftpd.backup
    5. vi ftpd (or use pico, or whichever editor you prefer)

    The start of the line may look like this:

    Code:
    service[ftpd]=21
    Since 21 is the default ftp port, and since you've moved ftpd to another port, replace "21" with the new port.

    If that doesn't help, then please see my signature for the URL to our helpdesk and open a ticket. Our technicians would be more than happy to assist you there, as that is the official location for support related requests.

    Please let me know how things work out.

    Thanks.
     
  4. mimran

    mimran Member

    Joined:
    Dec 16, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    thanks for the help,..
    I have used the second method, to change the port 21 to new port number,.

    Thanks.

    One small question?
    I'm trying to add cache control )header, and expires mod.

    I have added the following
    Code:
    <IfModule mod_expires.c>
    ExpiresActive on
    ExpiresByType image/jpg "access 1 month"
    ExpiresByType image/gif "access 1 month"
    ExpiresByType image/png "access 1 month"
    ExpiresByType application/x-shockwave-flash "access 1 month"
    ExpiresByType text/css "access 1 month"
    ExpiresByType text/html "access 1 day"
    ExpiresDefault "access 2 days"
    </IfModule>
    in httpd.conf but the cache values are not correct.
    Code:
    X-Powered-By: PHP/5.3.3
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-Encoding: gzip
    Vary: Accept-Encoding
    Set-Cookie: PHPSESSID=675ec7213b3eae2543fd84b33e90b6f3; path=/
    Keep-Alive: timeout=5, max=100
    Connection: Keep-Alive
    Transfer-Encoding: chunked
    
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,471
    Likes Received:
    199
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Different topic, you should start a new thread. Thanks.
     
  6. mimran

    mimran Member

    Joined:
    Dec 16, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    ok thanks,..

    By the way after making the changes I'm still getting these emails, do I need to restart anything after making changes?
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,471
    Likes Received:
    199
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes, I would think you'd want to restart the service:
    WHM > Restart Services > FTP Server (ProFTPd/PureFTPd)
     
  8. mimran

    mimran Member

    Joined:
    Dec 16, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Restarting from WHM gives error message that ftpd is not running, how ever restarting from ssh gives ok message and status is running...

    Edit: After a while the ftpd settings are reverting back to port 21.

    Is there anything that is making this change?
     
    #8 mimran, Nov 20, 2010
    Last edited: Nov 20, 2010
Loading...

Share This Page