The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Changed site IP address now httpd error?

Discussion in 'General Discussion' started by shortfork, Apr 27, 2008.

  1. shortfork

    shortfork Well-Known Member

    Joined:
    Sep 4, 2006
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    I changed a site's IP address in WHM and now when I do

    service httpd restart I get the following error

    NameVirtualHost xx.xx.xx.xx:80 has no VirtualHosts

    It lists same message twice for new IP address, once for old IP address..

    Site responds to IP address requests....

    Fix??

    Thanks in advance.

    Wayne
     
  2. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    If there's an entry in httpd.conf that looks like:

    NameVirtualHost 1.2.3.4:80

    and later there's no virtual host containers for 1.2.3.4:80 (maybe yours are only on 1.2.3.4), then you will get this error. It's a harmless error if the sites are functioning as expected.


    You may wish to have the sites and namevirtualhost entries match their ports to remove this error.
     
  3. shortfork

    shortfork Well-Known Member

    Joined:
    Sep 4, 2006
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for response.. went through and removed some unnecessary entries in httpd.conf that it seems (found via google research) cPanel puts into the file when you change ip addresses (as well as at other times)

    Anyway.. thanks, got it dialed!

    Wayne
     
Loading...

Share This Page