Changelog for 11.46.0.9: 116729: Ensure system Ruby is not installed on CentOS 5.

Trane Francks

Well-Known Member
Jun 19, 2012
103
19
68
Machida, Tokyo, Japan
cPanel Access Level
Root Administrator
May I please get clarification on exactly what this case entails for systems that are NOT running Rails support at the client level within cPanel settings? On one CentOS 5.11 server, we have compiled Phusion Passenger against an updated system-wide ruby 2.1.5 and have several Rails apps running under various cPanel accounts. If WHM 11.46 wholesale nukes my hard work, that server will need to stay on 11.44 indefinitely.

A related question: Does LTS 11.44 eventually have a forced upgrade to 11.46? If so, would you be so kind as to let me know the ETA for EOL of LTS 11.44? I have at least one client on this server that is running FrontPage extensions on his web site. ( Yeah, yeah, I know. :eek: )

Thanks.
 
Last edited:

Eric

Well-Known Member
Nov 25, 2007
753
12
143
Texas
cPanel Access Level
Root Administrator
Twitter
Howdy,

I believe you are talking about this case:
Case 116729: The Ruby shipped with CentOS 5 is 1.8.5, which is too old
to properly run rails. Ensure that we fail on such a system with an
error. Ensure that customers that have a modified Ruby keep that
version unless they run scripts/installruby. Furthermore, ensure that
a broken Ruby is reinstalled when running installruby. Finally, clean
up trailing whitespace.
On your related question you can stay on 11.44 forever but after a year you will stop getting security updates.

Thanks!
 

Trane Francks

Well-Known Member
Jun 19, 2012
103
19
68
Machida, Tokyo, Japan
cPanel Access Level
Root Administrator
Excellent. Thank you for the answers. We will target a change back to STABLE once Apache 2.2.x reaches EOL, at which time those users of FrontPage will either upgrade or find another hosting provider.
 
Last edited: