The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Changing domains to run on their own mail IP

Discussion in 'E-mail Discussions' started by biggsy, Jun 18, 2011.

  1. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hi there all,

    I have just changed a domain on my server to have its own IP address.

    I would like to set it so that when it sends out email, it sends from its own IP address. The domain has a mailing list of over 14,000 entries, all confirmed but I want to do this because I dont want the main server IP to get blacklisted. To clarify I am doing nothing wrong and all subscribers have consented. However - that doesnt stop them from reporting mail as spam.

    I know that I need to contact my server provider to add the rDNS entries, but what do I need to do in WHM on my side for it to be setup correctly?

    Thanks

    Andy
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Andy,

    In WHM > Exim Configuration Editor, please select the following:

    You would change from "Off" to "On" for each of these, then click the "Save" button.

    Please note that if the user has a mailing list using a script that uses sendmail or the PHP mail() function, it will bypass the exim configuration for these settings. The script must instead be using SMTP authentication for sending the emails. Mailman would use such authentication. Most scripts can be revised to use SMTP authentication rather than sendmail or the PHP mail() function, but I wanted you to be aware that anything bypassing exim to use sendmail will not be restricted to these settings and instead send using the main IP of the machine.
     
  3. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hi there, as soon as the first one:

    Automatically send outgoing mail from the account’s IP address instead of the main IP address. Warning: If you turn this setting on you should make sure reverse DNS entries match the ones in /etc/mail_reverse_dns. [?]

    Was turned on the other two below it you mentioned were greyed out so I was unable to select them.

    Basically if the first one is on then the other two are disabled.

    If I turn any of the second two on first then the first one becomes disabled.

    Any ideas?

    Thanks
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you select the first one, then the other two are going to automatically populate, so it is fine that you were only able to select the first one.
     
  5. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    After further looking, I think the first option selected is fine for what I need, I just need to get the rDNS entries in.

    Just want to make sure that 2 months down the line I dont get my main server IP blacklisted.

    Thanks
     
  6. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for that, I must have been typing while you were also.

    Is there any online tool I can use to test whihc IP a mail is being sent from, to double check its working. I just really need to be sure?

    Thanks

    Andy
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Simply send using one of the domains with a dedicated IP to a gmail or other address, then check the mail header for the email you've sent to that address.
     
  8. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Thanks, and finally. The domains on the server that I havent put rDNS entries for (the ones that dont have their own IP and have been on the server from day 1) will those be affected in any way e.g. stop working because I edited those exim settings?

    Thanks

    Andy
     
  9. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If the domain doesn't have its own IP, then it will use the main server IP to send out from and it cannot have its own rDNS entries due to using the main shared server IP. Those domains will not be impacted in any way.
     
  10. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Thanks, all working fine. Just one last question please.

    If a reseller has his own shared ip and a domain is assigned to that reseller what IP does it use and if it uses the main IP is there a way to make it use the resellers IP to mail from?

    Thanks so much for your kind, swift and informative help.
     
    #10 biggsy, Jun 19, 2011
    Last edited: Jun 19, 2011
  11. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Also I am getting this error saying my ip is blacklisted. But I read further into it but it says "its not blacklisted, we just dont trust it" what is that all about it says its because I have a generic rDNS?

     
  12. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Are you using rDNS entries on your IP? The IP provider would need to set a PTR record for each IP you have. Have you gotten ahold of your IP provider to request they create PTR records for each IP?
     
  13. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hi there, I can confirm that they DO have rdns entries.

    Thanks
     
  14. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    What is the IP in question? Without knowing the IP, I cannot confirm they have rDNS entries myself unfortunately.
     
  15. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hi, the ip is 213.5.181.35 and I managed to get the IP whitelisted at the spam list by adding them manually. Its crazy that these people block IP's with no evidence of any spam ever being sent.
     
  16. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I do see a PTR record for that IP:

    root@host [/usr/local/cpanel/scripts]# dig -x 213.5.181.35 +short
    netcomply.com.

    How long ago was the PTR (rDNS) setup for the IP, though? It can take 48-72 hours for many services to propagate the changes for the PTR record. Also, if you just recently changed the mailhelo and mail_reverse_dns for that IP in /etc/mailhelo and /etc/mail_reverse_dns files to match the PTR record, that IP will have a mismatch for the IP and the hostname until that was changed, since this is the hostname for the IP:

    root@host [/usr/local/cpanel/scripts]# telnet 213.5.181.35 25
    Trying 213.5.181.35...
    Connected to 213.5.181.35.
    Escape character is '^]'.
    220-srv1.k9webhost.com

    --> srv1.k9webhost.com

    Of course, the hostname must be different than an existing domain on the machine, since cPanel has the hostname set to user nobody, but I'm simply pointing out that any mismatch in the mailhelo by exim with the actual PTR of the IP will result in some recipients denying the messages. If you've set /etc/mailhelo and /etc/mail_reverse_dns to match the PTR record for the IP that also matches the domain's name, then exim will properly broadcast that domain name as the HELO response.
     
  17. biggsy

    biggsy Member

    Joined:
    Jan 20, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Cool, thanks for checking I thihnk it was just that one spam list NO MORE FUNN being an ass banning peoples IPs with no reason.

    Thanks for all your help.

    Andy
     
Loading...

Share This Page