changing from fpm to cgi - takes apache down

katmai

Well-Known Member
Mar 13, 2006
562
2
168
Brno, Czech Republic
Using cPanel/WHM 78 - found a bug.

If you're trying to switch a website that's on php-fpm to "off" aka cgi using the switch in multi-php menu, this will crash apache with the following error:

[Tue Feb 26 15:00:29.548729 2019] [mpm_event:notice] [pid 6913:tid 47629203768384] AH00493: SIGUSR1 received. Doing graceful restart
httpd: Syntax error on line 27188 of /etc/apache2/conf/httpd.conf: </VirtualHost>panel/cgi-priv/get_local.cgi> directive missing closing '>'


In order to get it back online i had to rebuild httpd.conf:

/usr/local/cpanel/scripts/php_fpm_config --rebuild
/scripts/rebuildhttpdconf
/scripts/restartsrv_apache_php_fpm
/scripts/restartsrv_httpd

Would be nice if this could get fixed, because i can't really have that much downtime while switching a site to non-fpm and then rebuilding or rebuilding after each site.

cheers,
rares
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
8,012
648
263
Houston
cPanel Access Level
DataCenter Provider
Hello @katmai

I'm currently unable to reproduce this issue. Here's what I did:

Go to WHM>>Software>>MultiPHP Manager -> Disabled System PHP-FPM -> Checked sites no change and no errors logged to apache config

Go to WHM>>Software>>MultiPHP Manager -> Disabled per-site PHP-FPM -> No errors logged.

Can you provide system information as well as cPanel version information along with detailed replication steps?

Thanks!