Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Changing outgoing IP for certain accounts - can't get it to work

Discussion in 'E-mail Discussion' started by bmett, Feb 5, 2012.

  1. bmett

    bmett Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Brisbane, AU
    Hi guys,

    Our mailserver has 100s of accounts and never caused us much of a problem. Lately the amount of compromised account and incidents with massive spam sending are becoming more regular.

    Therefore we are trying to change the outgoing (SMTP) IP for certain accounts. I had a good read through
    Changing the Sending IP for Outbound Email in Exim
    but can't get it to work.

    Following example.

    IP1: 123.123.123.1 main IP of the server, so far used for every account to send mails. no problem.
    IP2: 123.123.123.2 freshly new assigned IP, supposed to be used for certain accounts' outgoing server IP

    Firstly, the above article says to turn off
    In my WHM the option is called different:
    Couple of questions:
    • Does these accounts that are supposed to use the new IP to send mails need a dedicated IP? I hope not, since we want several accounts to use this new IP.

    • Does the above setting to be on or off? I'm really confused about it.

    The above the option also mentions the /etc/mail_reverse_dns file, but the tutorial only mentions /etc/mailhelo and /etc/mailips.

    I tried several things with these two/three files but not matter what the settings, the mails send via this account come up with IP1.

    I know that this is a very general call for help, but I still ope somebody can give me some advice. Maybe someone can tell me what exactly the above three files need to look like to get a certain acount to use IP2 when sending.

    Cheers,
    Bjorn
     
  2. antinportugal

    antinportugal Registered

    Joined:
    Nov 29, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    51
    Hello

    I´m in a similar situation and had been trying to implement the suggestions in the same article you linked to - without success so far.

    Did you manage to resolve this eventually ?

    Thanks

    Adrian
     
  3. arunsv84

    arunsv84 Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    373
    Likes Received:
    1
    Trophy Points:
    68
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
    Can you try the following?

    Go to WHM >> Exim Configuration Editor >> Enable "Reference /etc/mailips for outgoing SMTP connections" .
    Save the above configuration.
    Set the required ip in /etc/mailips

    eg: domain.tld: ipaddress

    Cheers!!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice