changing php handler from suPHP to FCGi gives permission problem

tombathgate

Registered
Jul 18, 2011
2
0
51
Hi All,

I am trying to change my php handler from suphp to FCGI which is fine and changes and websites run, however now I am experiencing permission errors.

In wordpress media manager when you try to upload an error using the flash uploader you get a http error, and the browser uploader gives a 500 error.

Wordpress is able to update it's files and update plugins but file uploads just won't work any more. I've checked the folder and it has a 755 permission. I've tried with 777 permissions and that doesn't work either.

I then created a test php upload script and that gives a 500 error so it seems to be uploading. I have checked the error logs and they are not capturing the problem.

I'm stumped as to what this can be, and googling has found nothing direct that works.

Any body have any ideas:

It's a vps running Cpanel v 11.30.1 (build 4)
php v5.3.6 running as fcgi, with suexec on (I have tried with it on and off and neither makes a difference)
Apache v 2.2

Everything else works except files uploads.

Thanks in advance

Tom
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Could you provide details on the exact plugin name for this Flash uploader or a link to it? I would like to install a copy of WordPress, switch my machine to FCGI and then check using that plugin, but I'm not familiar with it in WordPress and want to ensure I have the correct one I would be using for testing.
 

tombathgate

Registered
Jul 18, 2011
2
0
51
Hi Tristan,

The uploader is just the media flash uploader that is included as standard in Wordpress. I am using wordpress v3.2.1

if you install wordpress and the go to media in the menu and the click Add new and upload a picture and if it doens't work http error appears in red, or if you switch the browser upload, it gives the 500 error.

Thanks!

Tom
 

duimstra

Member
Jan 16, 2012
7
0
51
cPanel Access Level
Reseller Owner
I'm posting this for future reference, it might help someone that wil google this thread.

I had the same problem with WordPress and it turned out this was the culprit.
In your php.conf update this
Code:
FcgidMaxRequestLen 15728640
This will allow you to upload files up to 15 MB via PHP forms.
The default FastCGI setting is limited somewhere around 120kb - at least it was in our installation.