The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Chaning site to static IP creating issues

Discussion in 'General Discussion' started by rwoody, Oct 27, 2005.

  1. rwoody

    rwoody Member

    Jul 26, 2003
    Likes Received:
    Trophy Points:
    I am attempting to change an existing site from a shared IP to a static IP and I'm experience some strange behavior. When typing the sites URL, as long as the "www" is included in the typed address all is well, but as I often do, if I just type the url,, the default domain of the shared IP, which is my hosting site, appears and not the addressed site.

    I've gone all throught the httpd.conf, looking for errors, and I'm not really seeing anything that should create this issue. Exerpt from re: this account:

    DocumentRoot /home/thewell/public_html
    BytesLog domlogs/

    User thewell
    Group thewell
    CustomLog /usr/local/apache/domlogs/ combined
    ScriptAlias /cgi-bin/ /home/thewell/public_html/cgi-bin/

    I also deleted the account and recreated it assigning the static IP in the setup and still the same issue. Also, at the domain registrar level, only the name servers are provided, so it's not an issue there either.

    To be honest I've always had problems with this in the past anytime I change a site's IP address, it is a nightmare. I have one site, just the oposite... I had to assign a static IP, as when I listed it on the shared IP, I would once again have the default site appear instead of the correct site.

    My whm/cpanel build is:WHM 10.3.1 cPanel 10.4.0-C160

    I've read older posts (from 2002/2003) regarding this issue, but nothing recent and none of the posts provided a solution for me. Can someone let me know where else I should be looking to find configuration errors (other files etc?)

    This is really creating havoc for me so any help would much appreciated. I do have a ticket in to cPanel, but nothing yet... I was hoping someone had experience with this issue and a quick solution for me.

    Thanks in advance for any help offered
  2. sawbuck

    sawbuck Well-Known Member

    Jan 18, 2004
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    This IP ( is the static one you are trying to configure?
  3. Website Rob

    Website Rob Well-Known Member

    Mar 23, 2002
    Likes Received:
    Trophy Points:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Whenever you change an account on your Server, from a Shared IP to Dedicated or vica versa, there will be about a 6 hr. delay before the Internet DNS picks up the changes. That is normal and to be expected so you should advise any Client of such when doing so.

Share This Page