Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Character appended to autoresponder message

Discussion in 'E-mail Discussion' started by Stefaans, Nov 4, 2018.

  1. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    460
    Likes Received:
    3
    Trophy Points:
    318
    Location:
    Vancouver, Canada
    We are finding that an = character (equal sign) is appaended to the body of all autoresponder emails. Here is an example:
    This is happening on multiple servers (all the servers that I tested); not just one server or one domain. All of these servers are running WHM/cPanel ver. 74.0.10. I have upgraded one server to ver. 76.0.1 in the hope that the issue is addressed in case CPANEL-23461, but the problem persists.

    I am not seeing anyone else complaining about this on the cPanel Forums, so it would eppear that this is possibly related to our specific server configuration, e.g. custom Exim filter file, or custom configuration blocks in the Exim configuration.

    I would welcome comments from anyone else seeing this behaviour.

    Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Stefaans

    I'm not able to replicate this when I attempt to test on v76. Can you tell me about the server?

    1. OS
    Code:
    cat /etc/redhat-release
    2. Exim Customizations
    Code:
    cat /etc/exim.conf.local
    3. The actual AutoResponder
    Code:
    /home/$user/.autorespond
    As well as anything you think may be relevant to the issue.


    Please make sure to remove any personally identifying information from the responses.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    460
    Likes Received:
    3
    Trophy Points:
    318
    Location:
    Vancouver, Canada
    Thank you @cPanelLauren. Here is the bits of info:

    Code:
     cat /etc/redhat-release
    CentOS Linux release 7.5.1804 (Core)
    
    Code:
     cat /etc/exim.conf.local
    @AUTH@
    
    @BEGINACL@
    
    @CONFIG@
    chunking_advertise_hosts=""
    acl_smtp_dkim = acl_smtp_dkim
    daemon_smtp_ports = 25 : 465 : 587
    
    @DIRECTOREND@
    
    @DIRECTORMIDDLE@
    
    @DIRECTORSTART@
    
    @ENDACL@
    
    @POSTMAILCOUNT@
    
    @PREDOTFORWARD@
    
    @PREFILTER@
    
    @PRELOCALUSER@
    
    @PRENOALIASDISCARD@
    
    @PREROUTERS@
    
    @PREVALIASNOSTAR@
    
    @PREVALIASSTAR@
    
    @PREVIRTUALUSER@
    
    @RETRYEND@
    
    @RETRYSTART@
    
    @REWRITE@
    
    @ROUTEREND@
    
    @ROUTERMIDDLE@
    
    @ROUTERSTART@
    
    @TRANSPORTEND@
    
    @TRANSPORTMIDDLE@
    
    @TRANSPORTSTART@
    
    
    Code:
    cat /home/username/.autorespond/auto\@domain.com
    From: "me@domain.com" <auto@domain.com>
    Content-type: text/plain; charset=utf-8
    Subject: Automatic response
    
    This is an automatic response.
    and
    Code:
    cat /home/username/.autorespond/auto\@domain.com.json
    
    {"stop":null,"interval":0,"start":null}
    I hope you can spot something!

    Thanks,
    Stephen
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    HI @stefan2003

    Unfortunately, there is nothing telling in that information, but thank you for providing it. You mentioned the following:

    You showed me customizations to the exim configuration but what are the customizations to the Exim Filter file as well as specific server configuration that might be related to mail items?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    460
    Likes Received:
    3
    Trophy Points:
    318
    Location:
    Vancouver, Canada
    I have simplified things and taken all custom configurations out of the equation. I did this by using the Reset option in the Exim Configuration Manager with the option "Reset the entire Exim configuration to the default settings provided with cPanel & WHM". This changed nothing in the behaviour -- the trailing character still appears in the autoresponder body.

    I did this most recent test on WHM v76.0.6.

    How is this possible that I am the only one with this issue, and it is happening on multiple servers? :confused:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Stefaans

    It's got to be something specific to your configuration. I don't believe that the system filter is removed when you reset the configuration though and that might be a hint. Are you using any 3rd party software like ASSP or MailScanner?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    460
    Likes Received:
    3
    Trophy Points:
    318
    Location:
    Vancouver, Canada
    I have found and fixed the problem!

    The short version: This is 100% related to the following bug corrected in WHM v76.0.1:
    The long version: The issue with the trailing character in the autoresponder body persisted until I deleted it in cPanel, and then recreated it. After recreating the autoresponder in cPanel v76.0.1, it worked as expected with no trailing character. On comparing the autoresponder file /home/username/.autorespond/auto\@domain.com before (created with WHM v74.0.10) and after (created with WHM v76.0.1), it became clear that the latter included a final newline character that the former did not have. Subsequently, I tested on WHM v74.0.10 by manually adding an empty line at the end of the autoresponder (in cPanel), and the resulting autoresponder email worked fine.

    So, to fix the problem, do:
    • If you are using cPanel v76.0.1: Simply edit and save the autoresponder. This will add the needed newline character at the end of the body.
    • If you are using an older cPanel version: Edit the autoresponder in cPanel and add a blank line at the end of the message.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #7 Stefaans, Nov 9, 2018 at 3:09 PM
    Last edited: Nov 9, 2018 at 3:16 PM
  8. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,517
    Likes Received:
    251
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Stefaans

    Nice work, it would explain the inability to replicate the issue as the autoresponder needed to be removed and recreated which I was unaware of per the information on the case. Would also explain why new ones didn't experience the issue. Thanks for letting us know what you found and how you resolved it!


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice