The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

check_cpanel_rpms failed dependencies

Discussion in 'General Discussion' started by bojan050, Apr 9, 2014.

  1. bojan050

    bojan050 Member

    Joined:
    Dec 11, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I think I accidentally did something wrong (being somewhat of a NOOB) and I tried to make it right by executing : /scripts/check_cpanel_rpms. Unfortunately I got this error:


    [20140409.193621] error: Failed dependencies:
    [20140409.193621] libgd.so.2()(64bit) is needed by cpanel-webalizer-2.23_05-2.cp1136.x86_64
    [20140409.193621] W Error Code: 163
    [20140409.193621] E The following possible errors were detected while installing RPMs:
    [20140409.193621] E Failed dependencies

    I am running WHM 11.42.1 (build 5)

    Any ideas?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,830
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. bojan050

    bojan050 Member

    Joined:
    Dec 11, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi!

    These are the repos in that directory:

    centalt.repo
    CentOS-Base.repo
    CentOS-Debuginfo.repo
    CentOS-Media.repo
    CentOS-Vault.repo
    epel.repo
    epel-testing.repo
    mirrors-rpmforge
    mirrors-rpmforge-extras
    mirrors-rpmforge-testing
    newrelic.repo
    rpmforge.repo
     
  4. bojan050

    bojan050 Member

    Joined:
    Dec 11, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I am wondering, the rpm that causes the issue, cpanel-webalizer-2.23_05-2.cp1136.x86_64, is the only one with cp1136. That seems to me like an old version, as the rest of the rpms are 1142.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,830
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You have several custom repositories added to the /etc/yum.repos.d directory. It's likely a newer version of the GD libraries are installed on this server compared to what the cPanel Webalizer binaries have been compiled with. cPanel only supports using the stock CentOS, RHEL, or CloudLinux RPM package repositories. You will need to either downgrade GD 2.1 to GD 2.0, or to install both old and new versions of libgd at the same time. Note that you may want to remove the non-standard repo files to prevent further problems.

    Thank you.
     
Loading...

Share This Page