The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

checkperlmodules] perl version too old (v5.8.8 required, v5.8.7 is installed

Discussion in 'General Discussion' started by disappointed, Sep 4, 2007.

  1. disappointed

    disappointed Active Member

    May 25, 2007
    Likes Received:
    Trophy Points:
    followed cpanel instructions, now it complains about this and will not continue


    checked layer1... and that archive is not there

    gettnig messages from server about

    This module is required by cPanel, and the system may not function correctly until it is installed, and functional. Below is the results of the auto-install attempt:

    Test Run
    Can't locate loadable object for module Net::SSLeay in @INC (@INC contains: /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/site_perl/5.8.7/IO/Socket/ line 18 Compilation failed in require at /usr/lib/perl5/site_perl/5.8.7/IO/Socket/ line 18.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.7/IO/Socket/ line 18.
    Compilation failed in require at (eval 1) line 3.
    ...propagated at /usr/lib/perl5/5.8.8/ line 85.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Net/ line 12.
    Compilation failed in require at - line 1.
    BEGIN failed--compilation aborted at - line 1.

    Installer Run
    Fetching CPAN timestamp...Done
    Testing connection speed...(this could take a while)...Done
    Ping:2.347 Testing connection speed to using pureperl...(314900.00 bytes/s)...Done
    Ping:2.373 Testing connection speed to using pureperl...(157450.00 bytes/s)...Done Ping:1.710 Testing connection speed to using pureperl...(62620.00 bytes/s)...Done Three usable mirrors located Mirror Check passed for (/index.html) Unknown config variable 'less'
    commit: wrote '/usr/lib/perl5/5.8.8/CPAN/'
    CPAN: File::HomeDir loaded ok (v0.66)
    CPAN: Storable loaded ok (v2.16)
    Going to read /home/.cpan/Metadata
    Database was generated on Sat, 01 Sep 2007 23:36:41 GMT Running install for module 'Net::FTPSSL'
    Running make for K/KR/KRAL/Net-FTPSSL-0.04.tar.gz
    CPAN: Digest::SHA loaded ok (v5.45)
    CPAN: Compress::Zlib loaded ok (v1.42)
    Checksum for /home/.cpan/sources/authors/id/K/KR/KRAL/Net-FTPSSL-0.04.tar.gz ok Net-FTPSSL-0.04/ Net-FTPSSL-0.04/Changes Net-FTPSSL-0.04/ Net-FTPSSL-0.04/Makefile.PL Net-FTPSSL-0.04/MANIFEST Net-FTPSSL-0.04/META.yml Net-FTPSSL-0.04/README Net-FTPSSL-0.04/t/ Net-FTPSSL-0.04/t/00-basic.t Net-FTPSSL-0.04/t/10-complex.t
    CPAN: File::Temp loaded ok (v0.18) Going to build K/KR/KRAL/Net-FTPSSL-0.04.tar.gz

    Checking if your kit is complete...
    Looks good
    Warning: prerequisite IO::Socket::SSL 0 not found.
    Writing Makefile for Net::FTPSSL
    CPAN: YAML loaded ok (v0.65)
    cp blib/lib/Net/
    Manifying blib/man3/Net::FTPSSL.3
    /usr/bin/make -- OK
    Running make install
    Installing /usr/lib/perl5/site_perl/5.8.8/Net/
    Installing /usr/share/man/man3/Net::FTPSSL.3 Writing /usr/lib/perl5/site_perl/5.8.8/i686-linux/auto/Net/FTPSSL/.packlist
    Appending installation info to /usr/lib/perl5/5.8.8/i686-linux/perllocal.pod
    /usr/bin/make install UNINST=1 -- OK
    perlmod--Install done
    #1 disappointed, Sep 4, 2007
    Last edited: Sep 4, 2007

Share This Page