SOLVED checkquotas not running from command line or as part of upcp for mailbox usage

qcomber

Active Member
Nov 10, 2015
28
5
53
London
cPanel Access Level
Root Administrator
Yesterday I switched on the Tweak Settings -> Notifications -> Enable mailbox usage warnings, previously this has been set to Off (default).

I then manually ran /scripts/checkquotas and it ran as expected and delivered the required emails to notify of over quota accounts.

However, subsequently both manually and as part of upcp it returns:
manually:
/scripts/quotacheck
[quotacheck] Setting I/O priority to reduce system load: best-effort: prio 6
as part of upcp last night:
[2022-08-16 21:01:11 +0100] - Processing command `/usr/local/cpanel/scripts/quotacheck`
[2022-08-16 21:01:13 +0100] [/usr/local/cpanel/scripts/quotacheck] [quotacheck] Setting I/O priority to reduce system load: best-effort: prio 6
[2022-08-16 21:01:13 +0100] - Finished command `/usr/local/cpanel/scripts/quotacheck` in 2.008 seconds
and no over quota emails are received.

The system isn't under heavy load. The update upcp seems to complete successfully.

Other threads mention this but none seem to address it directly as they are more concerned with the update not completing successfully.

Edit:
Operating System CentOS v7.9.2009
Product cPanel & WHM v104.0.8 (STANDARD)
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
11,793
1,878
363
cPanel Access Level
Root Administrator
Hey there! Unless I'm misinterpreting this, this doesn't indicate an issue with the machine. The check is started, it basically sets up a "nice" value for itself so it doesn't use too many resources, and the check completes in 2 seconds. Are you seeing a problem with the quotacheck on the machine?
 

qcomber

Active Member
Nov 10, 2015
28
5
53
London
cPanel Access Level
Root Administrator
Hi Rex,

Many thanks for your response.

The issue remains that the over quota emails are not being sent either as part of upcp or by running /scripts/quotacheck from the cmd line.

I assumed that 'Setting I/O priority to reduce system load: best-effort: prio 6' means that the quotacheck is stopped due to system load. When I first ran /scripts/quotacheck manually on the cmd line, it reported which account(s) were overquota without the 'Setting I/O priority ...' message.

Pls advise.
 

qcomber

Active Member
Nov 10, 2015
28
5
53
London
cPanel Access Level
Root Administrator
Thanks Rex,

Please mark this thread as solved...

I confirm that /scripts/quotacheck is running correctly and is not stopping due to the 'Setting I/O priority to reduce system load: best-effort: prio 6' message. Load is therefore not an issue.

Just to confirm, my issue was/is that running subsequent /scripts/quotacheck's will not report on accounts which have already been found and informed in a previous quotacheck. They are written to '/var/cpanel/quotawarned' for this reason and this is normal functionality.

Some of our users will likely ignore the quotacheck emails (1) if they don't receive more than one of them [sigh]; and (2) due to branding. I need to now consider periodically removing the entries in /var/cpanel/quotawarned so that it sends more than one notification as part of upcp and also how to change the branding in the notification emails.