The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

chkservd and tomcat

Discussion in 'General Discussion' started by dgbaker, Dec 11, 2002.

  1. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    If you are using chkservd to monitor tomcat, you may need to add to the command.

    On occassion after a server reboot, tomcat may get hung up during startup. chkservd will try to run starttomcat, but will fail as tomcat is partially up and cannot connect to ports.

    If using chkservd for tomcat make the following change

    in /etc/chkserv.d
    pico tomcat
    change /usr/sbin/starttomcat to
    /usr/sbin/stoptomcat;/usr/sbin/starttomcat

    This will cause chkservd to ensure tomcat is not running at all by trying to stop any processes running and then do a clean start of tomcat.
     
  2. webline

    webline Member

    Joined:
    Nov 6, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Singapore
    i have done according to your instructions.
    but the status of tomcat doesn't seems to appear in the server status page of WHM.

    do i actually need to reboot or something? i have restarted tomcat server though.
     
  3. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    You also need to enable a port in web.xml for the monitor to use.
     
  4. webline

    webline Member

    Joined:
    Nov 6, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Singapore
    yes i did that too. followed exactly the instructions of one of your past thread. :)
     
Loading...

Share This Page