The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

chkservd gone now which proccess monitor http and other services?

Discussion in 'General Discussion' started by mahinder, Apr 6, 2009.

  1. mahinder

    mahinder Well-Known Member

    Joined:
    Jun 12, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    matrix
    i found chkservd is now completely removed by cpanel, the problem is whenever apache, ftp, exim fails tailwatchd do not restarts it automatically and service remain down.

    My Query: Which process now monitors http and other daemons and how to get cpanel check for process and restart them if they are not working?

    I have checked all services to be monitored in Service Manager.

    I also searched forums but did not find anything :(, sorry if this has been posted before.
     
    #1 mahinder, Apr 6, 2009
    Last edited: Apr 6, 2009
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    If you are not finding chkservd on your server, you may want to have our technical analysts look into fixing that for you: http://tickets.cpanel.net/submit
     
    #2 cPanelDavidG, Apr 6, 2009
    Last edited: May 6, 2009
  3. dorris

    dorris Member

    Joined:
    Mar 26, 2007
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    mine too

    Seems my chkservd is also dead, and nonexistant??
     
    #3 dorris, May 6, 2009
    Last edited: Mar 2, 2010
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    To everyone experiencing this issue, please submit a support ticket: http://tickets.cpanel.net/submit

    Doing this means technical analysts may be able to spot a trend so we can determine why this is happening on multiple servers.

    Thank you!
     
  5. dorris

    dorris Member

    Joined:
    Mar 26, 2007
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    my bad, it seems its not gone, but simply not what it used to be. it is now part of tailwatchd.

    my problem though is that http://MYSERVERURL:2086/scripts/servup, always shows
    exim (exim-4.69-15.1_cpanel_maildir) failed

    this is becoming quite a problem, as its forcing restarts of exim.
    if I remove the monitor from it, it seems to work just great, and stops restarting it every 5 minutes.

    trying to troubleshoot the issue, David, can you tell me if I am on the right track?
    should I log a ticket, or is this a known issue?

    my check script is:
    [root@dedi ~]# cat /etc/chkserv.d/exim
    service[exim]=25,QUIT,220,/etc/rc.d/init.d/exim stop;/etc/rc.d/init.d/exim stop;/etc/rc.d/init.d/exim stop;/etc/rc.d/init.d/exim start,exim,root|mailnull,220 |EHLO localhost|250 |AUTH PLAIN %service_auth_plain%|2|QUIT|2

    and when i telnet localhost port 25, and quit, I get :

    [root@dedi ~]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost (127.0.0.1).
    Escape character is '^]'.
    220-SRVNAME.xx.yyy ESMTP Exim 4.69 #1 Thu, 07 May 2009 10:47:41 +0200
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.
    quit
    221 sRVNAME.xx.yy closing connection
    Connection closed by foreign host.
    __________________________________________
     
    #5 dorris, May 7, 2009
    Last edited: Mar 2, 2010
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Hmm, that's identical to the chkserv.d script for exim on my test server. You may want to have our technical analysts take a look at things, figure out what is causing Exim to not run how chkserv.d anticipates it to be running.
     
  7. lehels

    lehels Well-Known Member

    Joined:
    Jul 10, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    I have the same issue,
    I can also observe that the problem, because of exim keeps reported failed by checksrvd, is about the authentification:

    ...exim [TCP Transaction Log:
    << 220-hostname ESMTP Exim 4.69 #1 Thu, 17 Sep 2009 20:40:03 +0300
    <<
    >> EHLO localhost
    << 250-hostname Hello localhost [127.0.0.1]
    <<
    >> AUTH PLAIN /CHARS/
    << 535 Incorrect authentication data
    exim: ** [535 Incorrect authentication data != 2]
    [check command:+][tcp connect:-]Restarting exim....

    Ok, the issue i may think is about an incorrect owner|group on some file, the question is which file is it.

    Thanks,
    Lehel
     
Loading...

Share This Page