Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED chkservd reports exim as down

Discussion in 'E-mail Discussion' started by madnoob2, Apr 17, 2019.

  1. madnoob2

    madnoob2 Active Member

    Joined:
    Apr 18, 2017
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Austria
    cPanel Access Level:
    Root Administrator
    Hi guys,

    today chkservd started reporting that exim is down, when it's not. Here's the log ;
    Code:
    TCP Transaction Log:
    << 220-cpanel.domain.com ESMTP Exim 4.91 #1 Wed, 17 Apr 2019 10:25:16 +0200
    << 220-We do not authorize the use of this system to transport unsolicited,
    << 220 and/or bulk e-mail.
    >> EHLO localhost
    << 250-cpanel.domain.com Hello localhost [127.0.0.1]
    << 250-SIZE 52428800
    << 250-8BITMIME
    << 250-PIPELINING
    << 250-STARTTLS
    << 250 HELP
    >> AUTH PLAIN
    somerandomstringhere
    << 503 AUTH command used when not advertised
    exim: ** [503 AUTH command used when not advertised != 2]
    : Died
    
    I'm not sure what exactly happened, but SMTP via port 25 is not working. TLS on 587 is working fine.
    The only option in exim I could think of to be related to this issue is ;
    "Require clients to connect with SSL or issue the STARTTLS command before they are allowed to authenticate with the server. [?] ON " which is ON by default. I turned this off and on last night in order to test something, but it's left at where it was.
    Also " Allow Plaintext Authentication (from remote clients) " is set to ON.

    Can someone point me in the right direction here? Thanks.
     
  2. madnoob2

    madnoob2 Active Member

    Joined:
    Apr 18, 2017
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Austria
    cPanel Access Level:
    Root Administrator
    Ignore, the directive I've set in exim did not want to remove itself
    "auth_advertise_hosts = ${if eq{$tls_in_cipher}{}{}{*}}"

    removed again and all good.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice