The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CL-selector not enabled by default

Discussion in 'CloudLinux' started by rkv_wwi, Sep 12, 2013.

  1. rkv_wwi

    rkv_wwi Member

    Joined:
    Jun 3, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    Greetings!

    I am having a problem with my new CloudLinux 6.4 / cPanel 11.38.2b6 host. When adding an account in the WHM interface, the PHP selector functionality does not enable until i force-update cagefs -- e.g.:

    Code:
    # cl-selector -p bob
    no
    
    # cagefsctl --list-enabled
    1 enabled user(s)
    bob
    
    # cagefsctl --force-update
    [ .. output .. ]
    
    # cl-selector -p bob
    y
    
    I remember the selector `just working` when I played around with the trial versions of CL/CP, and I can't figure out what I've done different this time around.

    The server is pretty vanilla, CloudLinux installed first, the cPanel immediately afterwards. That is to say, I don't remember whether I installed the lvemanager, cagefs, and alt-php packages before or after cPanel, but I've tried reinstalling in any event, to no avail.

    Any suggestions?

    Thanks in advance!

    R. Vestergaard
     
  2. iseletsk

    iseletsk Well-Known Member

    Joined:
    Mar 3, 2010
    Messages:
    163
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Princeton, New Jersey, United States
    Try: cagefsctl --update-etc
    If you add new user now that you did --force-update --> Is it still not working?
    If that is the case, please, submit a ticket to helpdesk.cloudlinux.com -- we will take a look.
     
  3. rkv_wwi

    rkv_wwi Member

    Joined:
    Jun 3, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    Hi Igor,

    --update-etc does not seem to have any effect. I'll hit the CL helpdesk as you suggested.

    Thanks,
    RV
     
  4. Tom Risager

    Tom Risager Well-Known Member

    Joined:
    Jul 10, 2012
    Messages:
    107
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Copenhagen, Denmark, Denmark
    cPanel Access Level:
    Root Administrator
    I've just been dealing with a similar issue that eventually got resolved by cPanel support (ticket 4340087).

    As it turned out the CageFS installer did not properly install a number of script hooks. Support ran this script which installed the missing hooks: /usr/share/cagefs/cpanel/cpanel-hooks-cagefs

    No issues with the PHP Selector since.
     
  5. rkv_wwi

    rkv_wwi Member

    Joined:
    Jun 3, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    Tom,

    That did indeed solve the problem! Now to study that script and find out what exactly went wrong...

    My other server, which exhibited the same symptoms, was fixed with assistance from the helpdesk. The problem turned out to be caused by an unpatched suphp (/usr/sbin/cpanel-compile-suphp.sh).

    Thank you very much for your assistance!

    R. Vestergaard
     
  6. Tom Risager

    Tom Risager Well-Known Member

    Joined:
    Jul 10, 2012
    Messages:
    107
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Copenhagen, Denmark, Denmark
    cPanel Access Level:
    Root Administrator
    You are most welcome, but credit really belongs to the helpful folks at cPanel support.

    I had the unpatched SuPHP issue too, which turned out to have the same root cause.

    Tom
     
Loading...

Share This Page