The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clam av uninstalled but still exists the icon on cpanel

Discussion in 'General Discussion' started by k-planethost, Sep 22, 2009.

  1. k-planethost

    k-planethost Well-Known Member

    Joined:
    Sep 22, 2009
    Messages:
    199
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Athens Greece
    a couple of days before i had installed clam av from cpanel root . I observe that the most of the time the cpu was overloaded so i decided finally to throw it away from the vps that buggy thing.
    From manage plugins i uninstall clam av uninstallation was succesfull but i observe that it still there is the antivirus icon to cpanels customers. you click it it says antivirus from clamav start scan and is doing nothing that thing.
    How can i move it from the whole cpanels that the vps has?
    thank you
    from root i had tried

    Code:
    /usr/local/cpanel/bin/rebuild_spritesIf that does not resolve the issue, try running the following via SSH as root:


    Code:
    touch /usr/local/cpanel/base/frontend/x3/dynamicui.conf

    but nothing still
     
  2. MattCurry

    MattCurry Well-Known Member

    Joined:
    Aug 18, 2009
    Messages:
    275
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Tx
    Clam AV

    Hello,


    I am sorry to see that you are having this issue. However, it appears that something is still hanging around. So we may need to take a closer look at your issue, and try getting you fixed up. Fastest way would be to submit a ticket via the link at the bottom of the post.

    Thank you,
    Matthew Curry
     
  3. Kent Brockman

    Kent Brockman Well-Known Member

    Joined:
    Jan 20, 2008
    Messages:
    1,130
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    I have exactly the same problem. I just wanted to give ClamAV a try but it has a very high memory footprint to run it in my vps.
    I decided to uninstall it but it have not gone completely: I have the icon on every customer panel and the LFD from the firewall detects the clamd service as not installed but system is trying to restart it "automagically".

    I've done a search on my server and this is found:

    Code:
    [root /]# locate clamd
    /usr/local/cpanel/etc/init/scripts/rhel/clamd
    /usr/local/cpanel/etc/init/scripts/debian/clamd
    /usr/local/cpanel/etc/init/scripts/centos/clamd
    /usr/local/cpanel/etc/init/scripts/mandrake/clamd
    /usr/local/cpanel/etc/init/scripts/redhat/clamd
    /usr/local/cpanel/etc/init/scripts/whitebox/clamd
    /usr/local/cpanel/etc/init/scripts/fedora/clamd
    /usr/local/cpanel/etc/init/scripts/caos/clamd
    /usr/local/cpanel/etc/init/scripts/freebsd/clamd.sh
    /usr/local/cpanel/etc/init/scripts/suse/clamd
    /usr/local/cpanel/etc/init/scripts/trustix/clamd
    /usr/local/cpanel/src/chkservd/chkserv.d/clamd
    /scripts/restartsrv_clamd
    /etc/clamd.conf
    /etc/chkserv.d/clamd
    /var/run/chkservd/clamd
    /var/clamd
    
    [root /]# locate clamav
    /usr/local/clamav
    /usr/local/clamav/mail
    /usr/local/cpanel/whostmgr/addonsfeatures/clamavconnector
    /usr/local/cpanel/base/frontend/x3/help/clamavconnector
    /usr/local/cpanel/base/frontend/x3/help/clamavconnector/index.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector
    /usr/local/cpanel/base/frontend/x3/clamavconnector/cleanstyle.css.gz
    /usr/local/cpanel/base/frontend/x3/clamavconnector/newscan.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector/scan.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector/cleanstyle.css
    /usr/local/cpanel/base/frontend/x3/clamavconnector/scanner.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector/bar.gif
    /usr/local/cpanel/base/frontend/x3/clamavconnector/ts.css
    /usr/local/cpanel/base/frontend/x3/clamavconnector/clam.gif
    /usr/local/cpanel/base/frontend/x3/clamavconnector/blank.gif
    /usr/local/cpanel/base/frontend/x3/clamavconnector/live_disinfect.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector/ts.css.gz
    /usr/local/cpanel/base/frontend/x3/clamavconnector/disinfect.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector/bars.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector/live_go.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector/blank.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector/index.html
    /usr/local/cpanel/base/frontend/x3/clamavconnector/clam.png
    /usr/share/logwatch/default.conf/services/clamav-milter.conf
    /usr/share/logwatch/default.conf/services/clamav.conf
    /usr/share/logwatch/scripts/services/clamav
    /usr/share/logwatch/scripts/services/clamav-milter
    /usr/share/clamav
    /usr/share/clamav/daily.cld
    /usr/share/clamav/main.cld
    /usr/share/clamav/mirrors.dat
    /etc/cpclamav.conf
    /var/cpanel/objcache/tn_clamavconnector.jpg
    /var/spool/mail/clamav
    
    Should I erase "/var/run/chkservd/clamd"?
    Any solution, please?
    Thanks!!
     
    #3 Kent Brockman, Mar 30, 2010
    Last edited: Mar 30, 2010
  4. GaryT

    GaryT Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    321
    Likes Received:
    3
    Trophy Points:
    16
    Is there a fix for this ?
     
  5. ManojB

    ManojB Well-Known Member

    Joined:
    Mar 25, 2005
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    pune
    You can remove clamav icon of cpanel by login into your WHM >> Feature Manager (Here disable this feature i.e., Uncheck the clamav feature)
     
  6. GaryT

    GaryT Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    321
    Likes Received:
    3
    Trophy Points:
    16
    yeah we done that but it still shows up in clients cpanel.
     
  7. WiredTree Joe

    WiredTree Joe Well-Known Member
    PartnerNOC

    Joined:
    Dec 13, 2006
    Messages:
    68
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Chicago, IL
    I find that even if you use the clamAV uninstall feature in Main >> cPanel >> Manage Plugins clamAV will remain in some form on the server. The trick, in most cases, is to disable clamd in Main >> Service Configuration >> Service Manager first and then uninstall it via Main >> cPanel >> Manage Plugins.

    This means if you have already uninstalled it via Main >> cPanel >> Manage Plugins -- Reinstall it and then disable it first in the service manager and then remove it from the server from the plugins section. I bet that will do the trick for you.
     
  8. GaryT

    GaryT Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    321
    Likes Received:
    3
    Trophy Points:
    16
    I did not see this at first but I submitted a ticket and they kindly fixed it.
     
Loading...

Share This Page