ckh

Well-Known Member
Dec 6, 2003
358
1
168
Phoenix, AZ
cPanel Access Level
DataCenter Provider
Anyone else having problems with ClamAV not working from within cPanel with 11.25 Current? Noticed it on several machines running Centos.

It works fine with the the latest 11.24 release, but, after the upgrade, it just won't scan. Says connecting to clamd service and that is it.
 

radeonpower

Well-Known Member
Jul 23, 2009
158
4
68
Iceland
cPanel Access Level
Root Administrator
Did you try MailScanner --lint? It seems to be working fine for me.

Checking for SpamAssassin errors (if you use it)...
Using SpamAssassin results cache
Connected to SpamAssassin cache database
SpamAssassin reported no errors.
Connected to Processing Attempts Database
Created Processing Attempts Database successfully
There are 0 messages in the Processing Attempts Database
Using locktype = posix
MailScanner.conf says "Virus Scanners = clamd"
Found these virus scanners installed: clamd
===========================================================================
Virus and Content Scanning: Starting
Clamd::INFECTED:: Eicar-Test-Signature :: ./1/
Clamd::INFECTED:: Eicar-Test-Signature :: ./1/eicar.com
Virus Scanning: Clamd found 2 infections
Virus Scanning: Found 2 viruses
===========================================================================

If any of your virus scanners (clamd)
are not listed there, you should check that they are installed correctly
and that MailScanner is finding them correctly via its virus.scanners.conf.
Config: calling custom end function MailWatchLogging
 

escalf

Member
PartnerNOC
Sep 30, 2006
12
0
151
I've noticed this, too. It doesn't appear to be scanning incoming mail, either. At least, I see zero indication of mail being scanned. This is on a freshly upgraded 11.25 system w/ clamav installed via plugins in WHM.

I've never run it under 11.24, but from my understanding, it's supposed to just "work".
 

venetsian

Registered
Nov 7, 2009
1
0
51
I'm on cPanel 11.25.0 with the same issue :-(

Is that CPanel bug or what?


Please update.

Venetsian
 

ckh

Well-Known Member
Dec 6, 2003
358
1
168
Phoenix, AZ
cPanel Access Level
DataCenter Provider
I just checked the ticket and cPanel gave this response:

Hello!

I have submitted a bug report for this issue as we are able to reproduce this on our test servers; I expect this to be fixed soon.

In the meantime you could have your customer run manual scans on his folders via crontab or command line until a fix is pushed out.
 

escalf

Member
PartnerNOC
Sep 30, 2006
12
0
151
Is there any way we could get the official bug report URL on this so those of us with interest can track it?
Thanks.