Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

ClamAV Command not found error

Discussion in 'Security' started by umarmeo, Jan 24, 2014.

  1. umarmeo

    umarmeo Member

    Joined:
    Jan 24, 2014
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,

    I have installed ClamAV via WHM and it is working fine if I scan a website from its cpanel account.
    But I want to scan accounts or full home dir via SSH.

    I am trying to run the command

    clamscan -ri /home
    clamscan -r -i /home

    but for every command which I am trying by searching I am getting
    -bash: clamscan: command not found

    Please guide me how to solve this issue.

    Thanks
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,802
    Likes Received:
    1,896
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Please utilize the following path for clamscan:

    Code:
    /usr/local/cpanel/3rdparty/bin/clamscan
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. umarmeo

    umarmeo Member

    Joined:
    Jan 24, 2014
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello

    I am not able to access this path. Please chrck below.



    root@xyz [~]# cd /usr/local/cpanel/3rdparty/bin/clamscan
    -bash: cd: /usr/local/cpanel/3rdparty/bin/clamscan: Not a directory
    root@xyz [~]#
     
  4. umarmeo

    umarmeo Member

    Joined:
    Jan 24, 2014
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello

    Sorry , I got it.

    First, I was thinking that I have to be in that directory to run commands. but it is working directly. :)

    Thank you.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice