The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ClamAV Connector - installation fails

Discussion in 'cPanel Developers' started by shacker23, Aug 15, 2005.

  1. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    I've got the cPanel Pro module enabled. Then select the ClamAV Connector module. It grabs sources, builds everything cleanly, downloads the virus definition databases. Then, just before it restarts exim, I get this:

    Exim version 4.51 #1 built 18-May-2005 20:55:40
    Copyright (c) University of Cambridge 2005
    Berkeley DB: Sleepycat Software: Berkeley DB 4.1.25: (August 21, 2003)
    Support for: iconv() PAM Perl OpenSSL Content_Scanning Old_Demime
    Lookups: lsearch wildlsearch nwildlsearch iplsearch dbm dbmnz
    Authenticators: cram_md5 plaintext spa
    Routers: accept dnslookup ipliteral manualroute queryprogram redirect
    Transports: appendfile autoreply pipe smtp
    Configuration file has an invalid syntax. Please try again.

    Exim actually does restart, mail services are working normally. It gives no clue as to what configuration file has the bad syntax, but clamav doesn't seem to be working. After I enable email scanning in the ClamAV Connector configuration page, I (and my customers) still get lots of those bogus "Your account is about to be suspended" (and similar) messages with viruses attached.

    What's the secret to getting the connector working properly? And which configuration file is the installer complaining about?

    Thanks,
    Scot
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Looks like you have a didgy exim configuration file. I'd suggest resetting it back to defaults:

    cd /etc
    mv exim.conf.local exim.conf.local.old
    /scripts/buildeximconf
    service exim restart
     
    gvard likes this.
  3. chris74108

    chris74108 Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    6
    I had a problem with clamav connector like this. All I did was remove clamav connector and then delete
    /etc/clamd.conf and resinstalled clamav connector. Works fine now.
     
  4. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    Chirpy, that did the trick. Many thanks!
     

Share This Page