The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ClamAV issue

Discussion in 'General Discussion' started by volex, Jul 1, 2009.

  1. volex

    volex Member
    PartnerNOC

    Joined:
    Feb 5, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have been experiencing this issue lately with ClamAV on one of our servers.

    Users are reporting failed uploads via cPanel file manager, the error shown is:

    Code:
    Virus Detected; File not Uploaded! (No such file or directory)
    When I have checked on the server ClamAV is not running, and attempting to restart it through /scripts/restartsrv_clamd it produces:

    Code:
    LibClamAV Warning: ***********************************************************
    LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    LibClamAV Error: Empty database file
    LibClamAV Error: Can't load /usr/share/clamav/malware.db: Malformed database
    ERROR: Malformed database
    this file shows up as:

    Code:
    -rw-r--r--   1 clamav clamav    0 Jun 29 08:23 malware.db
    If i delete this and restart it then it starts up without error. The problem is that this issue seems to be only solved temporarily, it comes back a few days later (this may be related to cPanel updating but I'm not entirely sure)

    If anyone can offer some advice it would be appreciated, thanks!
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
  3. PlatinumServerM

    PlatinumServerM Well-Known Member
    PartnerNOC

    Joined:
    Jul 10, 2005
    Messages:
    397
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    New Jersey, USA
    cPanel Access Level:
    Root Administrator
  4. volex

    volex Member
    PartnerNOC

    Joined:
    Feb 5, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have read the other thread but the problem is the advice works, but the issue just recurs very quickly. I delete the database file but then it comes back as a 0 byte file and this causes ClamAV to spit an error and fail to start.

    I have already tried uninstalling and reinstalling it but to no avail, exactly the same error occurs :/
     
  5. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I recommend submitting a support ticket so our technical analysts can work to diagnose the cause of this repeated corruption: http://tickets.cpanel.net/submit
     
Loading...

Share This Page