damainman

Well-Known Member
Nov 13, 2003
515
0
166
I've been out for a few days, and today i just tried to update CLAMAV using "freshclam" and got this:

ClamAV update process started at Sun Apr 25 13:03:34 2004
Reading CVD header (main.cvd): OK
main.cvd is up to date (version: 22, sigs: 20229, f-level: 1, builder: tkojm)
Reading CVD header (daily.cvd): OK
daily.cvd is up to date (version: 281, sigs: 989, f-level: 2, builder: tkojm)
WARNING: Your ClamAV installation is OUTDATED - please update immediately !
WARNING: Current functionality level = 1, required = 2


Does this release work with the layer1 package?
 
Last edited:

efeito

Well-Known Member
PartnerNOC
Jul 24, 2003
141
0
166
.pt
You should be using clamav-0.70-rc you will need to update to the final version clamav-0.70

Regards
 

bman

Well-Known Member
Dec 28, 2003
119
0
166
Originally posted by damainman
it works good with the mailscanner+clamav layer1 package?
does it ?
any one upgraded and found no problems running it with mailscanner on a cpanel server ?
thanks
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
I have no problems at all running the layer1 mailscanner, upgraded to the latest (see my howto in thie board) and the latest clamav running as clamavmodule and the latest Mail::ClamAV.
 

s55

Member
May 6, 2004
17
0
151
How do I install/upgrade to ClamAV 0.80?! I use mailscanner+clamav scanner too...
 

s55

Member
May 6, 2004
17
0
151
i think that this is what you want:

/etc/cron.daily/freshclam

Thank you...
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
No, it's the location of the binary that is important. Is it in /usr/bin/freshclam or is it in /usr/local/bin/freshclam?
 
P

paolorulez

Guest
[email protected] [~]# /etc/cron.daily/freshclam
ClamAV update process started at Fri Oct 29 11:12:39 2004
SECURITY WARNING: NO SUPPORT FOR DIGITAL SIGNATURES
Reading CVD header (main.cvd): OK
main.cvd is up to date (version: 27, sigs: 23982, f-level: 2, builder: tomek)
Reading CVD header (daily.cvd): OK
Downloading daily.cvd [*]
daily.cvd updated (version: 560, sigs: 1883, f-level: 3, builder: diego)
WARNING: Your ClamAV installation is OUTDATED - please update immediately !
WARNING: Current functionality level = 2, required = 3
Database updated (25865 signatures) from database.clamav.net


[email protected] [~]# rpm -qa | grep gmp
gmp-4.1.2-9

i have installed gmp library (gmp-4.1.3)
----------------------------------------------------------------------
Libraries have been installed in:
/usr/local/lib

but after recheck


[email protected] [~]# rpm -qa | grep gmp
gmp-4.1.2-9

why?
 

s55

Member
May 6, 2004
17
0
151
Thank you...

The only error that happen to me was:
ERROR: Please edit the example config file /usr/local/etc/freshclam.conf.
ERROR: Please edit the example config file /usr/local/etc/clamd.conf.
ERROR: Can't parse the config file /usr/local/etc/clamd.conf

Should be hurry about?!
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,481
35
208
cPanel Access Level
DataCenter Provider
s55 said:
Thank you...

The only error that happen to me was:
ERROR: Please edit the example config file /usr/local/etc/freshclam.conf.
ERROR: Please edit the example config file /usr/local/etc/clamd.conf.
ERROR: Can't parse the config file /usr/local/etc/clamd.conf

Should be hurry about?!
You compiled clamav manually without the sysconfigdir set to /etc
 

anand

Well-Known Member
Nov 11, 2002
1,432
1
168
India
cPanel Access Level
DataCenter Provider
s55 said:
Thank you...

The only error that happen to me was:
ERROR: Please edit the example config file /usr/local/etc/freshclam.conf.
ERROR: Please edit the example config file /usr/local/etc/clamd.conf.
ERROR: Can't parse the config file /usr/local/etc/clamd.conf

Should be hurry about?!
You didn't compile properly, as nick pointed out.

Use this to compile

./configure --prefix=/usr --sysconfdir=/etc

Then do make and make install. Remember you need to edit /etc/freshclam.conf and /etc/clamd.conf before you can start to use the new clam. Also many times i have seen old clam files don't get removed if they are being used, so either stop existing clamd or delete the files manually to ensure all new files are installed.
 

s55

Member
May 6, 2004
17
0
151
ERROR: Please edit the example config file /usr/local/etc/freshclam.conf.
ERROR: Please edit the example config file /usr/local/etc/clamd.conf.
ERROR: Can't parse the config file /usr/local/etc/clamd.conf


Can you tell me what I need to edit?!

Thank you...