SOLVED ClamAV version

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
6,815
541
263
Houston
cPanel Access Level
DataCenter Provider
On CentOS 6 the version is:

Code:
cpanel-clamav-0.100.2-1.cp1170.x86_64
On CentOS 7 it is:

Code:
cpanel-clamav-0.101.2-1.cp1180.x86_64
 

kernow

Well-Known Member
Jul 23, 2004
965
34
178
cPanel Access Level
Root Administrator
Were using MailScanner which may make a difference, a search shows we have two versions of Clam:
Code:
rpm -qa|grep clam
cpanel-clamav-virusdefs-0.101.2-1.cp1180.x86_64
clamav-0.99.4-1.el6.x86_64
clamav-db-0.99.4-1.el6.x86_64
cpanel-clamav-0.101.2-1.cp1180.x86_64
And its logwatch that's reporting an outdated version
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
6,815
541
263
Houston
cPanel Access Level
DataCenter Provider
Technically MailScanner should be able to use cPanel's ClamAV connector and you shouldn't need a separate ClamAV installation. This is noted on ConfigServer's site as well here: Installing ClamAV with MailScanner

The out of date ClamAV version is
Code:
clamav-0.99.4-1.el6.x86_64
clamav-db-0.99.4-1.el6.x86_64
As well
 

kernow

Well-Known Member
Jul 23, 2004
965
34
178
cPanel Access Level
Root Administrator
Thanks for all answers.
We decided to remove the older version with yum and in doing so we realised where the older version came from, dependencies to also be removed included imunify-antivirus which we tested and thought we had removed. I guess it installed an extra version of clamav.
Please mark 'Solved'
 
  • Like
Reactions: cPanelLauren