The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clamavconnector fails to install clamd on rhel5.5 x64

Discussion in 'General Discussion' started by boatdesign, May 18, 2010.

  1. boatdesign

    boatdesign Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    16
    On a new server (cPanel 11.25.0-S44718 - WHM 11.25.0 - X 3.9
    REDHAT Enterprise 5.5 x86_64 standard) clamavconnector is failing to actually install clamd. Is anyone else seeing this?

    checking check.h usability... no
    checking check.h presence... no
    checking for check.h... no
    configure: unable to compile/link with check

    ...

    make install-recursive
    make[2]: Entering directory `/usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64/clamav-0.96/libclamav'
    Making install in c++
    make[3]: Entering directory `/usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64/clamav-0.96/libclamav/c++'
    make install-am
    make[4]: Entering directory `/usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64/clamav-0.96/libclamav/c++'
    CXX libclamavcxx_la-bytecode2llvm.lo
    make[4]: Leaving directory `/usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64/clamav-0.96/libclamav/c++'
    make[3]: Leaving directory `/usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64/clamav-0.96/libclamav/c++'
    make[2]: Leaving directory `/usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64/clamav-0.96/libclamav'
    make[1]: Leaving directory `/usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64/clamav-0.96/libclamav'
    Unable to locate clamd
    Configuration file passes test! New configuration file was installed.

    The build from the WHM window is attached.

    WHM/Cpanel now includes it in the menu, but clamd does not actually appear nor freshclam, etc.

    # clamd -V
    -bash: clamd: command not found

    Is there another way to force clamd to install for the whm/cpanel clamavconnector for rhel5.5 x64? Any ideas?
     

    Attached Files:

  2. eperdeme

    eperdeme Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Manchester, UK
    cPanel Access Level:
    DataCenter Provider
    I had the same problem with my servers on 5.4

    I had to;

    cd /usr/local/cpanel/modules-install/clamavconnector-Linux-i686/

    ./install
     
  3. eperdeme

    eperdeme Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Manchester, UK
    cPanel Access Level:
    DataCenter Provider
    If you don't install it via WHM you don't get the exim config to do virus scanning on inbound mail. I guess you could edit the config or do it via the advanced editor, but we find it best to make the least changes to cPanel where possible.
     
  4. xerophyte

    xerophyte Well-Known Member

    Joined:
    Mar 16, 2003
    Messages:
    216
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    We normally use clamav from rpmforge .. you should not have any problem installing from there
     
  5. boatdesign

    boatdesign Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    16
    Thank you!

    That worked perfectly.

    On my other servers I've always installed it from whm and it went without any error. On this one for some reason it seemed to complete fine from whm except for the above but didn't actually install. I though about going with the rpm version but wasn't sure how that would mesh or affect future updates. But the above worked fine and now I have clamd, freshclam, etc. and it's working from the cpanel interface without issue.

    Thanks.
     
  6. wrender

    wrender Well-Known Member

    Joined:
    Sep 29, 2007
    Messages:
    69
    Likes Received:
    3
    Trophy Points:
    8
    With 64 Bit

    With a 64bit Centos 5.5 operating system. There is a folder /usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64]

    I just tried to do a ./install from there and it fails.

    cp: cannot stat `html/clamavconnector': No such file or directory
    mkdir: cannot create directory `/usr/local/cpanel/base/frontend/x/cells/': File exists
    cp: cannot stat `cells/clamavconnector.html': No such file or directory
    ln: creating symbolic link `./cells' to `../x/cells': File exists
    cp: cannot stat `whmaddons/clamavconnector': No such file or directory
    cp: cannot stat `addon_clamavconnector.cgi': No such file or directory
    zlib version checking was disabled. zlib versions <= 1.2.1 have a known security vulnerability
     
    #6 wrender, Jul 25, 2010
    Last edited: Jul 25, 2010
Loading...

Share This Page