The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clamavconnector HELP

Discussion in 'General Discussion' started by TISolutions, Aug 24, 2004.

  1. TISolutions

    TISolutions Registered

    Joined:
    Nov 14, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I installed the clamavconnector module and now i get no emails through server. then i do tail -f /var/log/exim_mainlog all i get is:

    2004-08-24 11:36:41 1BzdM7-0003hI-J3 H=(mx3.yourCasinoGamer.info) [213.31.217.235] F=<6h8f4v5@e-gamingbeat.info> temporarily rejected after DATA
    2004-08-24 11:39:19 1BzdOf-0003iX-9A malware acl condition: clamd: unable to connect to UNIX socket /usr/bin/clamscan (Permission denied)
    2004-08-24 11:39:19 1BzdOf-0003iX-9A H=(webmail-outgoing.us4.outblaze.com) [205.158.62.67] F=<daggdadman@mail.com> temporarily rejected after DATA


    all emails get temporarily rejected after DATA and the Permission denied error.

    Any help would be greatly appreciated.
     
  2. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    run /scripts/exim4 that did the trick for me.

    you may need to run the exiscan installer again, I did on one server.
     
  3. TISolutions

    TISolutions Registered

    Joined:
    Nov 14, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    after running /scripts/exim4 and running the exiscan installer again, everyting seems to be working great :D


    thanks :)
     
  4. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    sadly I have not found too much info on how to prevent this from happening ;)
     
  5. brentp

    brentp Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ayr, North Queensland, Australia
    ClamAV

    The clamav connector conflicts with the Exiscan-clamav thingo from cpanelappz.com. If you have one installed dont use the other.

    Regards,
    Brent
     
  6. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    Thanks!

    Interesting, I only installed the one from cpanelapzz that I knew of. How can I check to see that I have "clamav connector" set up already in my cpanel set up?
     
  7. brentp

    brentp Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ayr, North Queensland, Australia
    Well,

    Well i first fixed it by doing /scripts/exim4, then /scripts/upcp --force to the latest EDGE build. and i repeat, latest EDGE build :) Once you do that, see if the clamav connector is installed by going into root whm and going to "Addon Modules".

    If you need more help, i would be willing to login and fix it for you.

    Regards,
    Brent
     
  8. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    Thanks Brent, I will dig arround, I need to keep up on this sort of thing ;) Sometimes so busy doing the other stuff, I miss a new feature like this :D
     
Loading...

Share This Page